summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-03-03 23:54:21 +0000
committerMichael Imhof <tantive@gentoo.org>2004-03-03 23:54:21 +0000
commit43c6a2a8ff21dfb281de0c8a52e88e893139ea2b (patch)
treeedc99adea696dc5faa13fd65183810f3e9135461 /sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-43c6a2a8ff21dfb281de0c8a52e88e893139ea2b.tar.gz
gentoo-2-43c6a2a8ff21dfb281de0c8a52e88e893139ea2b.tar.bz2
gentoo-2-43c6a2a8ff21dfb281de0c8a52e88e893139ea2b.zip
Version bumped.
Diffstat (limited to 'sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild')
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild
new file mode 100644
index 000000000000..a4c84ec7ac72
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.0.4.ebuild,v 1.1 2004/03/03 23:54:21 tantive Exp $
+
+IUSE="crypt"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/glibc
+ !sys-cluster/mpich"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )"
+
+SLOT="6"
+KEYWORDS="~x86 ~amd64 ~alpha"
+LICENSE="as-is"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="--with-rsh=ssh"
+ else
+ myconf="--with-rsh=rsh"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ ${myconf} || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ #need to correct the produced absolute symlink
+ cd ${D}/usr/include
+ rm mpi++.h
+ ln -sf mpi2c++/mpi++.h mpi++.h
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+}