summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-04-17 13:07:20 +0000
committerMatti Bickel <mabi@gentoo.org>2009-04-17 13:07:20 +0000
commit1ea6ab66b92d2e0ee250dc796db39d7c0ddefd39 (patch)
treecc0832671d2f2599dbbee8d42490052439d668cb /sys-cluster/mpi-dotnet
parentVersion bump, and move to tarball and fake gemspec in the mean time. (diff)
downloadgentoo-2-1ea6ab66b92d2e0ee250dc796db39d7c0ddefd39.tar.gz
gentoo-2-1ea6ab66b92d2e0ee250dc796db39d7c0ddefd39.tar.bz2
gentoo-2-1ea6ab66b92d2e0ee250dc796db39d7c0ddefd39.zip
initial commit
(Portage version: 2.1.6.11/cvs/Linux ppc)
Diffstat (limited to 'sys-cluster/mpi-dotnet')
-rw-r--r--sys-cluster/mpi-dotnet/ChangeLog11
-rw-r--r--sys-cluster/mpi-dotnet/files/Makefile.am.patch22
-rw-r--r--sys-cluster/mpi-dotnet/files/Unsafe.pl.patch11
-rw-r--r--sys-cluster/mpi-dotnet/files/configure.ac.patch22
-rw-r--r--sys-cluster/mpi-dotnet/metadata.xml19
-rw-r--r--sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild62
6 files changed, 147 insertions, 0 deletions
diff --git a/sys-cluster/mpi-dotnet/ChangeLog b/sys-cluster/mpi-dotnet/ChangeLog
new file mode 100644
index 000000000000..f933ce052d91
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-cluster/mpi-dotnet
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpi-dotnet/ChangeLog,v 1.1 2009/04/17 13:07:20 mabi Exp $
+
+*mpi-dotnet-1.0.0 (17 Apr 2009)
+
+ 17 Apr 2009; Matti Bickel <mabi@gentoo.org> +files/Makefile.am.patch,
+ +files/Unsafe.pl.patch, +files/configure.ac.patch, +metadata.xml,
+ +mpi-dotnet-1.0.0.ebuild:
+ initial commit, restricting tests as they currently hang for me
+
diff --git a/sys-cluster/mpi-dotnet/files/Makefile.am.patch b/sys-cluster/mpi-dotnet/files/Makefile.am.patch
new file mode 100644
index 000000000000..195ea4c55f51
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/Makefile.am.patch
@@ -0,0 +1,22 @@
+--- mpi.net-1.0.0.orig/MPI/Makefile.am 2009-02-03 23:55:47.000000000 +0100
++++ mpi.net-1.0.0/MPI/Makefile.am 2009-02-03 23:56:18.000000000 +0100
+@@ -16,8 +16,8 @@
+ endif
+
+ SOURCES=$(srcdir)/Attribute.cs \
+- $(srcdir)/CartesianCommunicator.cs \
+- $(srcdir)/Communicator.cs \
++ $(srcdir)/CartesianCommunicator.cs \
++ $(srcdir)/Communicator.cs \
+ $(srcdir)/Comparison.cs \
+ $(srcdir)/DatatypeCache.cs \
+ $(srcdir)/Environment.cs \
+@@ -31,7 +31,7 @@
+ $(srcdir)/RequestList.cs \
+ $(srcdir)/Status.cs \
+ $(srcdir)/TagAllocator.cs \
+- $(srcdir)/TopologicalCommunicator.cs \
++ $(srcdir)/TopologicalCommunicator.cs \
+ $(srcdir)/UnmanagedMemoryStream.cs
+
+ # We want to install directly into /lib, but we can't write lib_SCRIPTS
diff --git a/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
new file mode 100644
index 000000000000..3f28c2a48326
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
@@ -0,0 +1,11 @@
+--- mpi.net-1.0.0.orig/MPI/Unsafe.pl 2009-02-03 23:55:48.000000000 +0100
++++ mpi.net-1.0.0/MPI/Unsafe.pl 2009-02-07 08:24:01.000000000 +0100
+@@ -96,7 +96,7 @@
+ }
+
+ # Grab the command-line arguments
+-$mpi_header=shift @ARGV;
++$mpi_header = (@ARGV > 3) ? shift @ARGV : "/usr/include/mpi.h";
+ $unsafe_input = shift @ARGV;
+ $unsafe_output = shift @ARGV;
+ $cbridge_output = shift @ARGV;
diff --git a/sys-cluster/mpi-dotnet/files/configure.ac.patch b/sys-cluster/mpi-dotnet/files/configure.ac.patch
new file mode 100644
index 000000000000..2c69aa1d5ce6
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/configure.ac.patch
@@ -0,0 +1,22 @@
+--- mpi.net-1.0.0.orig/configure.ac 2009-02-03 23:55:46.000000000 +0100
++++ mpi.net-1.0.0/configure.ac 2009-02-06 21:59:21.000000000 +0100
+@@ -202,9 +202,16 @@
+ AM_CONDITIONAL(MPINET_CBRIDGE, test "$need_cbridge" = "yes")
+
+ dnl Variable substitutions
+-AC_SUBST(MCS ILASM MONO MPIEXEC PERL
+- CSHARP_FLAGS CSHARP_DEFINES MPI_HEADER
+- MPI_SHARED_LIB_NAME MPI_FUNC_PREFIX)
++AC_SUBST(MCS)
++AC_SUBST(ILASM)
++AC_SUBST(MONO)
++AC_SUBST(MPIEXEC)
++AC_SUBST(PERL)
++AC_SUBST(CSHARP_FLAGS)
++AC_SUBST(CSHARP_DEFINES)
++AC_SUBST(MPI_HEADER)
++AC_SUBST(MPI_SHARED_LIB_NAME)
++AC_SUBST(MPI_FUNC_PREFIX)
+
+ AC_CONFIG_FILES([MPI/MPI.dll.config Tests/runtest.sh],[],[])
+
diff --git a/sys-cluster/mpi-dotnet/metadata.xml b/sys-cluster/mpi-dotnet/metadata.xml
new file mode 100644
index 000000000000..b79a713298bf
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hp-cluster</herd>
+ <maintainer>
+ <email>mabi@gentoo.org</email>
+ <name>Matti Bickel</name>
+ </maintainer>
+ <longdescription lang="en">
+ MPI.Net contains .Net (initially C#) bindings for at least any of these MPI libraries: Open MPI, LAM/MPI, and MPICH2.
+ </longdescription>
+ <use>
+ <flag name="doc">Install tutorials for C# and IronPython (requires a
+ Word document reader)</flag>
+ <flag name="examples">Install small, illustrative projects using
+ MPI.Net</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild b/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild
new file mode 100644
index 000000000000..c19318edd1b9
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpi-dotnet/mpi-dotnet-1.0.0.ebuild,v 1.1 2009/04/17 13:07:20 mabi Exp $
+
+WANT_AUTOTOOLS="2.5"
+inherit autotools mono
+
+# "." is not allowed as part of a package name
+MY_PN="mpi.net"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C# bindings for various MPI-implementations"
+HOMEPAGE="http://www.osl.iu.edu/research/mpi.net"
+SRC_URI="http://www.osl.iu.edu/research/mpi.net/files/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE="doc examples"
+
+RDEPEND="virtual/mpi
+ >=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+MPICC="${CC}"
+
+# tests hang at one point
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/configure.ac.patch"
+ epatch "${FILESDIR}/Makefile.am.patch"
+ epatch "${FILESDIR}/Unsafe.pl.patch"
+
+ # MPI/Makefile seems broken, fix it
+ eautoreconf
+}
+
+src_compile() {
+ # policy requires us to build shared and static libs alongside
+ econf --enable-shared --enable-static
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples ; then
+ insinto "${ROOT}/usr/share/doc/${PF}"
+ doins -r Examples
+ fi
+ use doc && dodoc Documentation/MPI.NET\ Tutorial{,\ Python}.doc
+}
+
+src_test() {
+ make check -k
+}