summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-10 17:03:23 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-10 17:03:23 +0000
commit3aa54533afeb0d8f8f5970a0d1eaadf2d8070e05 (patch)
tree2ad983457df9faf6710839f8fee178dd0ac0eff8 /sys-devel/llvm
parentUse a more portable and clobbering "cp" call for multibuild_merge_root(). (diff)
downloadgentoo-2-3aa54533afeb0d8f8f5970a0d1eaadf2d8070e05.tar.gz
gentoo-2-3aa54533afeb0d8f8f5970a0d1eaadf2d8070e05.tar.bz2
gentoo-2-3aa54533afeb0d8f8f5970a0d1eaadf2d8070e05.zip
Re-apply the install phase fixes for multilib-portage (bug #506398) and /tmp ownership (bug #506472). For now, just the live ebuild.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild28
2 files changed, 16 insertions, 18 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 145972df3b24..d54a5897a2d1 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.186 2014/04/07 20:59:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.187 2014/04/10 17:03:23 mgorny Exp $
+
+ 10 Apr 2014; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Re-apply the install phase fixes for multilib-portage (bug #506398) and /tmp
+ ownership (bug #506472). For now, just the live ebuild.
07 Apr 2014; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Update PYTHON_COMPAT in the live ebuild.
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 4fbd5e7beb9a..20b716512cc2 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.82 2014/04/07 20:59:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.83 2014/04/10 17:03:23 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-inherit cmake-utils eutils flag-o-matic git-r3 multilib multilib-minimal \
- python-r1 toolchain-funcs pax-utils check-reqs
+inherit cmake-utils eutils flag-o-matic git-r3 multibuild multilib \
+ multilib-minimal python-r1 toolchain-funcs pax-utils check-reqs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -65,6 +65,10 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# so why did it call itself ninja in the first place?
CMAKE_MAKEFILE_GENERATOR=emake
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/llvm-config
+)
+
pkg_pretend() {
# in megs
# !clang !debug !multitarget -O2 400
@@ -371,25 +375,15 @@ multilib_src_install() {
local MAKEARGS
set_makeargs
- emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ local root=${D}/_${ABI}
- # Preserve ABI-variant of llvm-config.
- dodir /tmp
- mv "${ED}"/usr/bin/llvm-config "${ED}"/tmp/"${CHOST}"-llvm-config || die
+ emake "${MAKEARGS[@]}" DESTDIR="${root}" install
+ multibuild_merge_root "${root}" "${D}"
if ! multilib_build_binaries; then
- # Drop all the executables since LLVM doesn't like to
- # clobber when installing.
- rm -r "${ED}"/usr/bin || die
-
# Backwards compat, will be happily removed someday.
- dosym "${CHOST}"-llvm-config /tmp/llvm-config.${ABI}
+ dosym "${CHOST}"-llvm-config /usr/bin/llvm-config.${ABI}
else
- # Move files back.
- mv "${ED}"/tmp/*llvm-config* "${ED}"/usr/bin || die
- # Create a symlink for host's llvm-config.
- dosym "${CHOST}"-llvm-config /usr/bin/llvm-config
-
# Install docs.
doman "${S}"/docs/_build/man/*.1
use clang && doman "${T}"/clang.1