summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-07 04:25:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-07 04:25:57 +0000
commitdbc9025e89062171f1e8b95ba40b0c45797e4217 (patch)
tree96d307747e18a3a96e88aed82a2d452f6ab9b8b7 /sys-devel/sparse
parentold (diff)
downloadgentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.tar.gz
gentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.tar.bz2
gentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.zip
Respect user CFLAGS #361853 by Nathan Phillip Brink.
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/ChangeLog8
-rw-r--r--sys-devel/sparse/sparse-0.4.3.ebuild8
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index c78822a4d546..3dd665988d61 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/sparse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.39 2010/12/09 16:34:54 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.40 2011/04/07 04:25:57 vapier Exp $
+
+ 07 Apr 2011; Mike Frysinger <vapier@gentoo.org> sparse-0.4.3.ebuild,
+ sparse-9999.ebuild:
+ Respect user CFLAGS #361853 by Nathan Phillip Brink.
*sparse-0.4.3 (09 Dec 2010)
diff --git a/sys-devel/sparse/sparse-0.4.3.ebuild b/sys-devel/sparse/sparse-0.4.3.ebuild
index 121b7bcf67e8..bab5bb790a90 100644
--- a/sys-devel/sparse/sparse-0.4.3.ebuild
+++ b/sys-devel/sparse/sparse-0.4.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.3.ebuild,v 1.1 2010/12/09 16:34:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.3.ebuild,v 1.2 2011/04/07 04:25:57 vapier Exp $
EAPI="2"
-inherit eutils multilib flag-o-matic toolchain-funcs
+inherit multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
inherit git
@@ -29,8 +29,8 @@ src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions::}' \
Makefile || die
- append-flags -fno-strict-aliasing
export MAKEOPTS+=" V=1 CC=$(tc-getCC)"
}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index d375721bc7ba..2c1974073bd7 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.5 2010/10/05 08:41:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.6 2011/04/07 04:25:57 vapier Exp $
EAPI="2"
-inherit eutils multilib flag-o-matic toolchain-funcs
+inherit multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
inherit git
@@ -29,8 +29,8 @@ src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions::}' \
Makefile || die
- append-flags -fno-strict-aliasing
export MAKEOPTS+=" V=1 CC=$(tc-getCC)"
}