summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-17 03:34:44 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-17 03:34:44 +0000
commit568b96fef66dbd1228bb54b9a1cb4b96cdf0d456 (patch)
treea8d458348f2cb0787cbd63ccb76a19f71951f9ac /sys-fs/quotatool
parentRemove old. (diff)
downloadgentoo-2-568b96fef66dbd1228bb54b9a1cb4b96cdf0d456.tar.gz
gentoo-2-568b96fef66dbd1228bb54b9a1cb4b96cdf0d456.tar.bz2
gentoo-2-568b96fef66dbd1228bb54b9a1cb4b96cdf0d456.zip
Version bump #452394 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-fs/quotatool')
-rw-r--r--sys-fs/quotatool/ChangeLog10
-rw-r--r--sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch23
-rw-r--r--sys-fs/quotatool/quotatool-1.4.13.ebuild27
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-fs/quotatool/ChangeLog b/sys-fs/quotatool/ChangeLog
index ef245e8880d7..5a97cef6c5fe 100644
--- a/sys-fs/quotatool/ChangeLog
+++ b/sys-fs/quotatool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/quotatool
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/ChangeLog,v 1.10 2012/02/23 07:09:01 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/ChangeLog,v 1.11 2013/01/17 03:34:44 vapier Exp $
+
+*quotatool-1.4.13 (17 Jan 2013)
+
+ 17 Jan 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/quotatool-1.4.13-ldflags.patch, +quotatool-1.4.13.ebuild:
+ Version bump #452394 by Agostino Sarubbo.
*quotatool-1.4.12 (23 Feb 2012)
diff --git a/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch b/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
new file mode 100644
index 000000000000..d73f02f8ce81
--- /dev/null
+++ b/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
@@ -0,0 +1,23 @@
+--- quotatool-1.4.13/local.mk.in
++++ quotatool-1.4.13/local.mk.in
+@@ -17,7 +17,8 @@
+
+ CC := @CC@
+ CFLAGS := @CFLAGS@
+-CPPFLAGS = $(inc) @DEFS@
++LDFLAGS := @LDFLAGS@
++CPPFLAGS = @CPPFLAGS@ $(inc) @DEFS@
+
+
+ INSTALL := @INSTALL@
+--- quotatool-1.4.13/Makefile
++++ quotatool-1.4.13/Makefile
+@@ -58,7 +58,7 @@
+ # compile the program (and the objects)
+ all: $(prog)
+ $(prog): $(objs)
+- $(CC) -o $(prog) $(objs) $(libs) $(CFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(prog) $(objs) $(libs)
+
+
+
diff --git a/sys-fs/quotatool/quotatool-1.4.13.ebuild b/sys-fs/quotatool/quotatool-1.4.13.ebuild
new file mode 100644
index 000000000000..a4143cded23e
--- /dev/null
+++ b/sys-fs/quotatool/quotatool-1.4.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/quotatool-1.4.13.ebuild,v 1.1 2013/01/17 03:34:44 vapier Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="command-line utility for filesystem quotas"
+HOMEPAGE="http://quotatool.ekenberg.se/"
+SRC_URI="http://quotatool.ekenberg.se/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/quota"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.13-ldflags.patch
+}
+
+src_install () {
+ dodir /usr/sbin /usr/share/man/man8
+ default
+}