summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-24 09:46:16 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-24 09:46:16 +0000
commitc3cdda375a37f792c5b0ff3dc3b46fa85cc9bc57 (patch)
treee8b9f26d2f725d9dfd059d2bd455cbcf47ef5fd7 /sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild
parentVersion bump. Bug #408309 (diff)
downloadgentoo-2-c3cdda375a37f792c5b0ff3dc3b46fa85cc9bc57.tar.gz
gentoo-2-c3cdda375a37f792c5b0ff3dc3b46fa85cc9bc57.tar.bz2
gentoo-2-c3cdda375a37f792c5b0ff3dc3b46fa85cc9bc57.zip
Version bump.
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild')
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild
new file mode 100644
index 000000000000..8019d2ce60bf
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.26.ebuild,v 1.1 2012/03/24 09:46:16 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="22"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+ UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+else
+ TUXONICE_SRC="http://www.tuxonice.net/files/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+ UNIPATCH_LIST="${DISTDIR}/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch.bz2"
+fi
+
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}