summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-25 03:30:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-25 03:30:44 +0000
commit0c25425c536d8acd352839e24cd562cf978bff5a (patch)
treedb89d5dce5c33ebf0aa50c039440877f2141e197 /www-servers/pound
parentReally fix libexecdir #462668 (diff)
downloadgentoo-2-0c25425c536d8acd352839e24cd562cf978bff5a.tar.gz
gentoo-2-0c25425c536d8acd352839e24cd562cf978bff5a.tar.bz2
gentoo-2-0c25425c536d8acd352839e24cd562cf978bff5a.zip
Bump for #462380
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/ChangeLog9
-rw-r--r--www-servers/pound/pound-2.7a.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 906ec2a14428..e4d9dd2a4490 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.51 2012/09/30 18:44:23 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.52 2013/03/25 03:30:44 patrick Exp $
+
+*pound-2.7a (25 Mar 2013)
+
+ 25 Mar 2013; Patrick Lauer <patrick@gentoo.org> +pound-2.7a.ebuild:
+ Bump for #462380
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> pound-2.5.ebuild:
Move to ~alpha
diff --git a/www-servers/pound/pound-2.7a.ebuild b/www-servers/pound/pound-2.7a.ebuild
new file mode 100644
index 000000000000..d51f64e4148d
--- /dev/null
+++ b/www-servers/pound/pound-2.7a.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.7a.ebuild,v 1.1 2013/03/25 03:30:44 patrick Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/p/P}
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+HOMEPAGE="http://www.apsis.ch/pound/"
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}