summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-22 22:26:40 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-22 22:26:40 +0000
commit67692e38e17c0bf86f66a0fbcaa774b595bf4bf0 (patch)
treede09d7c7a1898c886045f6a6a7cbf40d91f0a4dc /x11-libs
parentVersion bump. This version compiles only with a kernel 2.6.8 and newer. It do... (diff)
downloadgentoo-2-67692e38e17c0bf86f66a0fbcaa774b595bf4bf0.tar.gz
gentoo-2-67692e38e17c0bf86f66a0fbcaa774b595bf4bf0.tar.bz2
gentoo-2-67692e38e17c0bf86f66a0fbcaa774b595bf4bf0.zip
made arch specific config file patch apply on x86 when CONF_LIBDIR=lib32. this is just to make building the emul-linux-x86-gtklibs package easier, and has no effect on x86 users in general.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/gtk+-2.4.4.ebuild7
-rw-r--r--x11-libs/gtk+/gtk+-2.4.7.ebuild7
3 files changed, 19 insertions, 3 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index f71ed3f46307..dba5844cd3e9 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.114 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.115 2004/08/22 22:26:40 lv Exp $
+
+ 22 Aug 2004; Travis Tilley <lv@gentoo.org> gtk+-2.4.4.ebuild,
+ gtk+-2.4.7.ebuild:
+ made arch specific config file patch apply on x86 when CONF_LIBDIR=lib32. this
+ is just to make building the emul-linux-x86-gtklibs package easier, and has no
+ effect on x86 users in general.
22 Aug 2004; Travis Tilley <lv@gentoo.org> gtk+-2.4.4.ebuild,
gtk+-2.4.7.ebuild:
diff --git a/x11-libs/gtk+/gtk+-2.4.4.ebuild b/x11-libs/gtk+/gtk+-2.4.4.ebuild
index 2d2090ffecb4..f3a8f4bb35fa 100644
--- a/x11-libs/gtk+/gtk+-2.4.4.ebuild
+++ b/x11-libs/gtk+/gtk+-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.4.ebuild,v 1.7 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.4.ebuild,v 1.8 2004/08/22 22:26:40 lv Exp $
inherit libtool flag-o-matic eutils
@@ -44,6 +44,9 @@ src_unpack() {
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
use amd64 && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
autoconf || die
automake || die
@@ -75,6 +78,7 @@ src_install() {
dodir /etc/gtk-2.0
use amd64 && dodir /etc/gtk-2.0/${CHOST}
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
make DESTDIR=${D} install || die
@@ -89,6 +93,7 @@ src_install() {
pkg_postinst() {
use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
diff --git a/x11-libs/gtk+/gtk+-2.4.7.ebuild b/x11-libs/gtk+/gtk+-2.4.7.ebuild
index 806003f07b7c..2c497938cef0 100644
--- a/x11-libs/gtk+/gtk+-2.4.7.ebuild
+++ b/x11-libs/gtk+/gtk+-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.7.ebuild,v 1.2 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.7.ebuild,v 1.3 2004/08/22 22:26:40 lv Exp $
inherit libtool flag-o-matic eutils
@@ -44,6 +44,9 @@ src_unpack() {
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
use amd64 && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
autoconf || die
automake || die
@@ -75,6 +78,7 @@ src_install() {
dodir /etc/gtk-2.0
use amd64 && dodir /etc/gtk-2.0/${CHOST}
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
make DESTDIR=${D} install || die
@@ -89,6 +93,7 @@ src_install() {
pkg_postinst() {
use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules