summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-05 13:18:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-05 13:18:48 +0000
commitad4da9d6502b5ef7805ae654b6e59f86af00a86f (patch)
tree25ab3746f09571debe59abea2064ab7a16a1eedf /x11-libs
parentEAPI 5 (diff)
downloadgentoo-2-ad4da9d6502b5ef7805ae654b6e59f86af00a86f.tar.gz
gentoo-2-ad4da9d6502b5ef7805ae654b6e59f86af00a86f.tar.bz2
gentoo-2-ad4da9d6502b5ef7805ae654b6e59f86af00a86f.zip
version bump, bug #534378
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva/ChangeLog9
-rw-r--r--x11-libs/libva/libva-1.5.0.ebuild82
2 files changed, 89 insertions, 2 deletions
diff --git a/x11-libs/libva/ChangeLog b/x11-libs/libva/ChangeLog
index 6515c1ef1425..0cccf681b4de 100644
--- a/x11-libs/libva/ChangeLog
+++ b/x11-libs/libva/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libva
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.64 2014/11/03 10:25:21 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.65 2015/01/05 13:18:48 aballier Exp $
+
+*libva-1.5.0 (05 Jan 2015)
+
+ 05 Jan 2015; Alexis Ballier <aballier@gentoo.org> +libva-1.5.0.ebuild:
+ version bump, bug #534378
03 Nov 2014; Alexis Ballier <aballier@gentoo.org> libva-9999.ebuild:
drop patch on live ebuild, it was merged upstream. not sure why this was even
diff --git a/x11-libs/libva/libva-1.5.0.ebuild b/x11-libs/libva/libva-1.5.0.ebuild
new file mode 100644
index 000000000000..dadc11c3ad67
--- /dev/null
+++ b/x11-libs/libva/libva-1.5.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.5.0.ebuild,v 1.1 2015/01/05 13:18:48 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
+
+VIDEO_CARDS="dummy nvidia intel fglrx"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? ( >=x11-libs/xvba-video-0.8.0-r1[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="opengl? ( X )"
+
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}