summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-13 12:54:28 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-13 12:54:28 +0000
commitf0379f21af3b1c5e7a0b4127239b49ebd1a28b19 (patch)
tree842793dd9a842e328f6f8fed5a9d3a426899525e /x11-misc/trayer-srg
parentdrop old (diff)
downloadgentoo-2-f0379f21af3b1c5e7a0b4127239b49ebd1a28b19.tar.gz
gentoo-2-f0379f21af3b1c5e7a0b4127239b49ebd1a28b19.tar.bz2
gentoo-2-f0379f21af3b1c5e7a0b4127239b49ebd1a28b19.zip
Version bump, vcs-snapshot eclass.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/trayer-srg')
-rw-r--r--x11-misc/trayer-srg/ChangeLog8
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild7
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild32
3 files changed, 40 insertions, 7 deletions
diff --git a/x11-misc/trayer-srg/ChangeLog b/x11-misc/trayer-srg/ChangeLog
index e84641681519..bc9d2c407cb3 100644
--- a/x11-misc/trayer-srg/ChangeLog
+++ b/x11-misc/trayer-srg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/trayer-srg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/ChangeLog,v 1.3 2012/05/05 04:53:47 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/ChangeLog,v 1.4 2012/06/13 12:54:28 xmw Exp $
+
+*trayer-srg-1.1.5 (13 Jun 2012)
+
+ 13 Jun 2012; Michael Weber <xmw@gentoo.org> +trayer-srg-1.1.5.ebuild,
+ trayer-srg-1.1.4.ebuild:
+ Version bump, vcs-snapshot eclass.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> trayer-srg-1.1.4.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild
index c17caa95c1eb..997149c61ea2 100644
--- a/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild,v 1.2 2012/05/05 04:53:47 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/trayer-srg-1.1.4.ebuild,v 1.3 2012/06/13 12:54:28 xmw Exp $
EAPI=4
@@ -22,11 +22,6 @@ RDEPEND="x11-libs/gdk-pixbuf:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- mv *-${PN}-* ${P} || die
-}
-
src_compile() {
emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
}
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild
new file mode 100644
index 000000000000..d5452e98ae4b
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild,v 1.1 2012/06/13 12:54:28 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}