summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/mod_auth_kerb/ChangeLog6
-rw-r--r--net-www/mod_auth_kerb/Manifest16
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild18
3 files changed, 21 insertions, 19 deletions
diff --git a/net-www/mod_auth_kerb/ChangeLog b/net-www/mod_auth_kerb/ChangeLog
index 0b520b28408c..60a2b5517740 100644
--- a/net-www/mod_auth_kerb/ChangeLog
+++ b/net-www/mod_auth_kerb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mod_auth_kerb
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.7 2005/01/30 15:18:40 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.8 2005/02/17 10:41:37 hollow Exp $
+
+ 17 Feb 2005; Benedikt Boehm <hollow@gentoo.org>
+ mod_auth_kerb-5.0_rc6.ebuild:
+ added apache 1.3 support + clean up
*mod_auth_kerb-5.0_rc6 (30 Jan 2005)
diff --git a/net-www/mod_auth_kerb/Manifest b/net-www/mod_auth_kerb/Manifest
index bdb6a9e8c7c0..7c08cd1722e2 100644
--- a/net-www/mod_auth_kerb/Manifest
+++ b/net-www/mod_auth_kerb/Manifest
@@ -1,21 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 6eba02cec68a2992338abdcfce084267 ChangeLog 932
+MD5 a3a3238e07052001e5aeee54d2e7305a ChangeLog 1053
MD5 0d18f0fe5d603b41b988373892caf195 metadata.xml 226
MD5 862f1e12609fd86384b8bae627fab5cf mod_auth_kerb-4.11-r1.ebuild 864
MD5 305a2884f3d786ee45d11ca24a2f5859 mod_auth_kerb-4.11.ebuild 1079
-MD5 3b115a819daf7108561b7a57c1ab329a mod_auth_kerb-5.0_rc6.ebuild 797
+MD5 257882eeb97b1b57b3d9bfe491de6f0c mod_auth_kerb-5.0_rc6.ebuild 1010
MD5 c9bbfd002811a674505b3844837a63ee files/11_mod_auth_kerb.conf 180
MD5 7e465f540fb90976cd1c7959ae94e6ab files/digest-mod_auth_kerb-4.11 69
MD5 7e465f540fb90976cd1c7959ae94e6ab files/digest-mod_auth_kerb-4.11-r1 69
-MD5 05d525e36b7e86f564e3a15608eca8e4 files/mod_auth_kerb_register.patch 782
MD5 738a52c466673dc44a3cd64f54d85390 files/digest-mod_auth_kerb-5.0_rc6 72
+MD5 05d525e36b7e86f564e3a15608eca8e4 files/mod_auth_kerb_register.patch 782
MD5 09472a6ada3ceb33b8ff34c863691651 files/4.11-r1/11_mod_auth_kerb.conf 132
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB/PrpmPFBzbX68WERAhYVAJ4gxEIOBsBiq05iiHJG8OgXieOirgCeLYJF
-p2IApBcnNMet4CEEi/kIflU=
-=0iWu
------END PGP SIGNATURE-----
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
index 04bbd9c5c412..9a75b00bc51e 100644
--- a/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.1 2005/01/30 15:18:40 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.2 2005/02/17 10:41:39 hollow Exp $
MY_PV=${PV/_rc/-rc}
@@ -15,18 +15,26 @@ KEYWORDS="~x86"
IUSE=""
SLOT="0"
-S="${WORKDIR}/${PN}-${MY_PV}"
DEPEND="app-crypt/mit-krb5"
RDEPEND=""
+APACHE1_MOD_CONF="4.11-r1/11_${PN}"
+APACHE1_MOD_DEFINE="AUTH_KERB"
+
APACHE2_MOD_CONF="4.11-r1/11_${PN}"
APACHE2_MOD_DEFINE="AUTH_KERB"
DOCFILES="INSTALL README"
-need_apache2
+need_apache
+
+S=${WORKDIR}/${PN}-${MY_PV}
src_compile() {
- CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
- emake
+ if use apache2; then
+ CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ else
+ CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ fi
+ emake || die "make failed"
}