summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/mapnik/ChangeLog10
-rw-r--r--sci-geosciences/mapnik/files/mapnik-0.7.1-libagg.patch35
-rw-r--r--sci-geosciences/mapnik/mapnik-0.7.1.ebuild130
3 files changed, 174 insertions, 1 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index 6c9ea9f7ca05..3c9a50674368 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.17 2010/06/17 21:01:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.18 2010/10/18 02:54:59 nerdboy Exp $
+
+*mapnik-0.7.1 (18 Oct 2010)
+
+ 18 Oct 2010; Steve Arnold <nerdboy@gentoo.org> +mapnik-0.7.1.ebuild,
+ +files/mapnik-0.7.1-libagg.patch:
+ Updated to new version for new gpsdrive and boost support (among other
+ things). Tested with boost-1.42, gpsd-2.95, and gpsdrive-2.11 (and a
+ USB gps device).
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> mapnik-0.5.1.ebuild,
mapnik-0.6.0.ebuild, mapnik-0.6.1-r3.ebuild:
diff --git a/sci-geosciences/mapnik/files/mapnik-0.7.1-libagg.patch b/sci-geosciences/mapnik/files/mapnik-0.7.1-libagg.patch
new file mode 100644
index 000000000000..a0294edb031f
--- /dev/null
+++ b/sci-geosciences/mapnik/files/mapnik-0.7.1-libagg.patch
@@ -0,0 +1,35 @@
+--- SConstruct 2010-03-24 13:47:52.000000000 +0100
++++ SConstruct 2010-03-24 13:50:29.000000000 +0100
+@@ -260,10 +260,12 @@
+ PathVariable('TIFF_LIBS', 'Search path for libtiff library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
+ PathVariable('PROJ_INCLUDES', 'Search path for PROJ.4 include files', '/usr/include', PathVariable.PathAccept),
+ PathVariable('PROJ_LIBS', 'Search path for PROJ.4 library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
++ PathVariable('AGG_INCLUDES', 'Search path for AGG include files', '/usr/include/agg2', PathVariable.PathAccept),
++ PathVariable('AGG_LIBS', 'Search path for AGG library files', '/usr/' + LIBDIR_SCHEMA, PathVariable.PathAccept),
+ ('PKG_CONFIG_PATH', 'Use this path to point pkg-config to .pc files instead of the PKG_CONFIG_PATH environment setting',''),
+
+ # Variables affecting rendering back-ends
+- BoolVariable('INTERNAL_LIBAGG', 'Use provided libagg', 'True'),
++ BoolVariable('INTERNAL_LIBAGG', 'Use provided libagg', 'False'),
+
+ # Variables for optional dependencies
+ # Note: cairo, cairomm, and pycairo all optional but configured automatically through pkg-config
+@@ -799,6 +801,7 @@
+ ['jpeg', ['stdio.h', 'jpeglib.h'], True,'C'],
+ ['proj', 'proj_api.h', True,'C'],
+ [env['ICU_LIB_NAME'],'unicode/unistr.h',True,'C++'],
++ ['agg','agg2/agg_config.h' , True,'C++'],
+ ]
+
+
+--- src/SConscript 2010-03-24 13:51:08.000000000 +0100
++++ src/SConscript 2010-03-24 13:52:17.000000000 +0100
+@@ -36,7 +36,7 @@
+ filesystem = 'boost_filesystem%s' % env['BOOST_APPEND']
+ regex = 'boost_regex%s' % env['BOOST_APPEND']
+
+-libraries = ['freetype','ltdl','png','tiff','z','jpeg','proj',env['ICU_LIB_NAME'],filesystem,regex]
++libraries = ['freetype','ltdl','png','tiff','z','jpeg','proj',env['ICU_LIB_NAME'],'agg',filesystem,regex]
+
+ if '-DHAVE_CAIRO' in env['CXXFLAGS']:
+ # add cairo and cairomm-1.0 to libs
diff --git a/sci-geosciences/mapnik/mapnik-0.7.1.ebuild b/sci-geosciences/mapnik/mapnik-0.7.1.ebuild
new file mode 100644
index 000000000000..9d8922266288
--- /dev/null
+++ b/sci-geosciences/mapnik/mapnik-0.7.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.7.1.ebuild,v 1.1 2010/10/18 02:54:59 nerdboy Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="python? 2"
+inherit eutils python distutils toolchain-funcs versionator
+
+DESCRIPTION="A Free Toolkit for developing mapping applications."
+HOMEPAGE="http://www.mapnik.org/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cairo curl debug doc +gdal postgres python sqlite"
+
+RDEPEND="dev-libs/boost
+ dev-libs/icu
+ dev-libs/libxml2
+ media-fonts/dejavu
+ media-libs/freetype:2
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/tiff
+ sci-libs/proj
+ x11-libs/agg[truetype]
+ cairo? (
+ x11-libs/cairo
+ dev-cpp/cairomm
+ )
+ curl? ( net-misc/curl )
+ gdal? ( sci-libs/gdal )
+ postgres? (
+ >=dev-db/postgresql-base-8.0
+ >=dev-db/postgis-1.1.2
+ )
+ python? ( dev-libs/boost[python] )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.0.0
+ doc? ( dev-python/epydoc )
+"
+
+src_prepare() {
+ sed -i \
+ -e "s|/usr/local|/usr|g" \
+ -e "s|Action(env\[config\]|Action('%s --help' % env\[config\]|" \
+ SConstruct || die
+
+ sed -i \
+ -e "s:mapniklibpath + '/fonts':'/usr/share/fonts/dejavu/':g" \
+ bindings/python/SConscript || die "sed 1 failed"
+ rm -rf agg || die
+ epatch "${FILESDIR}"/${P}-libagg.patch
+}
+
+src_configure() {
+ MAKEOPTS="SYSTEM_FONTS=/usr/share/fonts/dejavu"
+
+ MAKEOPTS="${MAKEOPTS} INPUT_PLUGINS="
+ use postgres && MAKEOPTS="${MAKEOPTS}postgis,"
+ use gdal && MAKEOPTS="${MAKEOPTS}gdal,ogr,"
+ use sqlite && MAKEOPTS="${MAKEOPTS}sqlite,"
+ use curl && MAKEOPTS="${MAKEOPTS}osm,"
+ MAKEOPTS="${MAKEOPTS}shape,raster"
+
+ use cairo || MAKEOPTS="${MAKEOPTS} CAIRO=false"
+ use python || MAKEOPTS="${MAKEOPTS} BINDINGS=none"
+ use debug && MAKEOPTS="${MAKEOPTS} DEBUG=yes"
+
+ use postgres && use sqlite && MAKEOPTS="${MAKEOPTS} PGSQL2SQLITE=yes"
+
+ BOOST_PKG="$(best_version "dev-libs/boost")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ export BOOST_VERSION="$(replace_all_version_separators _ "${BOOST_VER}")"
+ elog "${P} BOOST_VERSION is ${BOOST_VERSION}"
+ export BOOST_INC="/usr/include/boost-${BOOST_VERSION}"
+ elog "${P} BOOST_INC is ${BOOST_INC}"
+ BOOST_LIBDIR_SCHEMA="$(get_libdir)/boost-${BOOST_VERSION}"
+ export BOOST_LIB="/usr/${BOOST_LIBDIR_SCHEMA}"
+ elog "${P} BOOST_LIB is ${BOOST_LIB}"
+
+ # Passing things doesn't seem to hit all the right paths; another
+ # poster-child for just a bit too much complexity for its own good.
+ # See bug #301674 for more info.
+# sed -i -e "s|BOOST_INCLUDE_DIR = None|BOOST_INCLUDE_DIR = \'${BOOST_INC}\'|" \
+# -i -e "s|BOOST_LIB_DIR = None|BOOST_LIB_DIR = \'${BOOST_LIB}\'|" \
+ sed -i -e "s|searchDir, LIBDIR_SCHEMA|searchDir, \'${BOOST_LIBDIR_SCHEMA}\'|" \
+ -i -e "s|include/boost*|include/boost-${BOOST_VERSION}|" \
+ "${S}"/SConstruct || die "sed boost paths failed..."
+
+ scons CXX="$(tc-getCXX)" ${MAKEOPTS} DESTDIR="${D}" configure \
+ || die "scons configure failed"
+}
+
+src_compile() {
+ scons BOOST_INCLUDES=${BOOST_INC} BOOST_LIBS=${BOOST_LIB} \
+ BOOST_VERSION=${BOOST_VERSION} || die "scons make failed"
+ if use doc; then
+ export PYTHONPATH="${S}/bindings/python:$(python_get_sitedir)"
+ cd docs/epydoc_config
+ ./build_epydoc.sh || die "API doc generation failed"
+ cd -
+ fi
+}
+
+src_install() {
+ scons BOOST_INCLUDES=${BOOST_INC} BOOST_LIBS=${BOOST_LIB} \
+ BOOST_VERSION=${BOOST_VERSION} install || die "scons install failed"
+
+ if use python ; then
+ fperms 0755 "$(python_get_sitedir)"/mapnik/paths.py
+ dobin utils/stats/mapdef_stats.py
+ insinto /usr/share/doc/${PF}/examples
+ doins utils/ogcserver/*
+ fi
+
+ dodoc AUTHORS CHANGELOG README || die
+ use doc && { dohtml -r docs/api_docs/python/* || die "API doc install failed"; }
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See the home page or the OpenStreetMap wiki for more info, and"
+ elog "the installed examples for the default mapnik ogcserver config."
+ elog ""
+}