summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-scheme/guile/ChangeLog7
-rw-r--r--dev-scheme/guile/guile-1.6.8.ebuild12
-rw-r--r--dev-scheme/guile/guile-1.8.4-r1.ebuild12
-rw-r--r--dev-scheme/guile/guile-1.8.4.ebuild15
-rw-r--r--dev-scheme/guile/guile-1.8.5-r1.ebuild8
-rw-r--r--dev-scheme/guile/guile-1.8.5.ebuild10
-rw-r--r--dev-scheme/guile/guile-1.8.6.ebuild6
-rw-r--r--dev-scheme/guile/guile-1.8.7.ebuild6
8 files changed, 50 insertions, 26 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index 866a0aeb7895..9bfe6c235da5 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/guile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.80 2010/11/14 15:53:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.81 2010/11/14 16:05:58 jlec Exp $
+
+ 14 Nov 2010; Justin Lecher <jlec@gentoo.org> guile-1.6.8.ebuild,
+ guile-1.8.4.ebuild, guile-1.8.4-r1.ebuild, guile-1.8.5.ebuild,
+ guile-1.8.5-r1.ebuild, guile-1.8.6.ebuild, guile-1.8.7.ebuild:
+ QA on quoting, empty lines, ebuild style
*guile-1.8.7-r2 (14 Nov 2010)
diff --git a/dev-scheme/guile/guile-1.6.8.ebuild b/dev-scheme/guile/guile-1.6.8.ebuild
index d2736f7de6a3..465ff76ee6b0 100644
--- a/dev-scheme/guile/guile-1.6.8.ebuild
+++ b/dev-scheme/guile/guile-1.6.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.6.8.ebuild,v 1.15 2008/02/20 12:57:47 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.6.8.ebuild,v 1.16 2010/11/14 16:05:58 jlec Exp $
inherit flag-o-matic eutils libtool
@@ -15,8 +15,10 @@ IUSE=""
# bug 179738
MAKEOPTS="${MAKEOPTS} -j1"
-DEPEND=">=sys-libs/ncurses-5.1
+DEPEND="
+ >=sys-libs/ncurses-5.1
>=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
# NOTE: in README-PACKAGERS, guile recommends different versions be installed
# in parallel. They're talking about LIBRARY MAJOR versions and not
@@ -43,7 +45,7 @@ src_compile() {
econf \
--with-threads \
--with-modules \
- --enable-deprecation=no || die
+ --enable-deprecation=no
# Please keep --enable-deprecation=no in future bumps.
# Danny van Dyk <kugelfang@gentoo.org 2004/09/19
@@ -54,7 +56,7 @@ src_compile() {
src_install() {
einstall || die "install failed"
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS || die
# texmacs needs this, closing bug #23493
dodir /etc/env.d
diff --git a/dev-scheme/guile/guile-1.8.4-r1.ebuild b/dev-scheme/guile/guile-1.8.4-r1.ebuild
index 9968e7934f0b..4631838fa3cb 100644
--- a/dev-scheme/guile/guile-1.8.4-r1.ebuild
+++ b/dev-scheme/guile/guile-1.8.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.4-r1.ebuild,v 1.3 2009/07/31 17:26:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.4-r1.ebuild,v 1.4 2010/11/14 16:05:58 jlec Exp $
EAPI=1
inherit eutils autotools flag-o-matic
@@ -13,7 +13,11 @@ LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
+DEPEND="
+ >=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore
@@ -69,7 +73,7 @@ src_compile() {
src_install() {
einstall || die "install failed"
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS || die
# texmacs needs this, closing bug #23493
dodir /etc/env.d
diff --git a/dev-scheme/guile/guile-1.8.4.ebuild b/dev-scheme/guile/guile-1.8.4.ebuild
index 3138f6cd5fdc..5c5d9e4e5ded 100644
--- a/dev-scheme/guile/guile-1.8.4.ebuild
+++ b/dev-scheme/guile/guile-1.8.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.4.ebuild,v 1.10 2009/10/19 00:32:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.4.ebuild,v 1.11 2010/11/14 16:05:58 jlec Exp $
EAPI=1
-inherit eutils autotools flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Scheme interpreter"
HOMEPAGE="http://www.gnu.org/software/guile/"
@@ -13,7 +13,11 @@ LICENSE="LGPL-2.1"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
+DEPEND="
+ >=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore
@@ -56,8 +60,7 @@ src_compile() {
src_install() {
einstall || die "install failed"
-
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS || die
# texmacs needs this, closing bug #23493
dodir /etc/env.d
diff --git a/dev-scheme/guile/guile-1.8.5-r1.ebuild b/dev-scheme/guile/guile-1.8.5-r1.ebuild
index f3ac9a982657..0e1a9c8b67ed 100644
--- a/dev-scheme/guile/guile-1.8.5-r1.ebuild
+++ b/dev-scheme/guile/guile-1.8.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.11 2009/10/19 00:32:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.12 2010/11/14 16:05:58 jlec Exp $
EAPI=1
inherit eutils autotools flag-o-matic elisp-common
@@ -13,10 +13,12 @@ LICENSE="LGPL-2.1"
KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1
+DEPEND="
+ >=dev-libs/gmp-4.1
>=sys-devel/libtool-1.5.6
sys-devel/gettext
emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore
diff --git a/dev-scheme/guile/guile-1.8.5.ebuild b/dev-scheme/guile/guile-1.8.5.ebuild
index a7693394c98c..b23d2e8565db 100644
--- a/dev-scheme/guile/guile-1.8.5.ebuild
+++ b/dev-scheme/guile/guile-1.8.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5.ebuild,v 1.3 2009/07/31 17:26:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5.ebuild,v 1.4 2010/11/14 16:05:58 jlec Exp $
EAPI=1
inherit eutils autotools flag-o-matic
@@ -13,7 +13,11 @@ LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
+DEPEND="
+ >=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore
diff --git a/dev-scheme/guile/guile-1.8.6.ebuild b/dev-scheme/guile/guile-1.8.6.ebuild
index c3796b3053ae..e739e799075d 100644
--- a/dev-scheme/guile/guile-1.8.6.ebuild
+++ b/dev-scheme/guile/guile-1.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.6.ebuild,v 1.4 2010/03/08 22:46:31 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.6.ebuild,v 1.5 2010/11/14 16:05:58 jlec Exp $
EAPI=1
inherit flag-o-matic elisp-common
@@ -13,10 +13,12 @@ LICENSE="LGPL-2.1"
KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1
+DEPEND="
+ >=dev-libs/gmp-4.1
>=sys-devel/libtool-1.5.6
sys-devel/gettext
emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore
diff --git a/dev-scheme/guile/guile-1.8.7.ebuild b/dev-scheme/guile/guile-1.8.7.ebuild
index 63426ef05edb..90259ec6d528 100644
--- a/dev-scheme/guile/guile-1.8.7.ebuild
+++ b/dev-scheme/guile/guile-1.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.7.ebuild,v 1.3 2010/05/30 06:10:46 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.7.ebuild,v 1.4 2010/11/14 16:05:58 jlec Exp $
EAPI=1
inherit eutils autotools flag-o-matic elisp-common
@@ -14,10 +14,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
IUSE="networking +regex discouraged +deprecated elisp emacs nls debug-freelist debug-malloc debug +threads"
RESTRICT="!regex? ( test )"
-DEPEND=">=dev-libs/gmp-4.1
+DEPEND="
+ >=dev-libs/gmp-4.1
>=sys-devel/libtool-1.5.6
sys-devel/gettext
emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
# but there are lots of collisions. Most in /usr/share/libguile. Therefore