summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/ChangeLog8
-rw-r--r--app-admin/paxtest/files/paxtest-0.9.7_pre5-Makefile.patch50
-rw-r--r--app-admin/paxtest/files/paxtest-0.9.7_pre5-missing-includes.patch44
-rw-r--r--app-admin/paxtest/paxtest-0.9.7_pre5.ebuild66
-rw-r--r--app-admin/paxtest/paxtest-0.9.9-r1.ebuild81
5 files changed, 7 insertions, 242 deletions
diff --git a/app-admin/paxtest/ChangeLog b/app-admin/paxtest/ChangeLog
index 13572734cc6c..c4a26bd7a7ce 100644
--- a/app-admin/paxtest/ChangeLog
+++ b/app-admin/paxtest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/paxtest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.42 2011/04/23 13:54:18 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.43 2011/05/03 14:58:16 blueness Exp $
+
+ 03 May 2011; Anthony G. Basile <blueness@gentoo.org>
+ -paxtest-0.9.7_pre5.ebuild, -files/paxtest-0.9.7_pre5-Makefile.patch,
+ -files/paxtest-0.9.7_pre5-missing-includes.patch,
+ -paxtest-0.9.9-r1.ebuild:
+ Removed versions depending on sys-apps/chpax, see bug #365825
*paxtest-0.9.9-r2 (23 Apr 2011)
diff --git a/app-admin/paxtest/files/paxtest-0.9.7_pre5-Makefile.patch b/app-admin/paxtest/files/paxtest-0.9.7_pre5-Makefile.patch
deleted file mode 100644
index 1b258423d249..000000000000
--- a/app-admin/paxtest/files/paxtest-0.9.7_pre5-Makefile.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile 2006-03-21 15:33:21.000000000 +0100
-+++ Makefile 2009-06-29 22:46:43.623289281 +0200
-@@ -58,7 +58,7 @@ DUMMY := $(shell echo '${PAXCTLBIN} $$*'
- endif
-
- # for some reason the .c files need it, else GNU_STACK=RWE
--OPT_FLAGS := -O2 $(ASFLAGS)
-+OPT_FLAGS := $(CFLAGS) $(ASFLAGS)
- PTHREAD := -lpthread
- # define stripping of binaries/libs here, or set these on make's commandline,
- # else you'll loose the chpax flags!
-@@ -134,7 +134,7 @@ paxtest: $(TESTS) genpaxtest
-
- $(EXEC_TESTS) $(MPROT_TESTS): body.o
- $(CC) $(CFLAGS) -o $@.o -c $@.c
-- $(CC) $(LDFLAGS) $(PTHREAD) -o $@ $< $@.o
-+ $(CC) $(LDFLAGS) -o $@ $< $@.o $(PTHREAD)
-
- $(RAND_TESTS): randbody.o
- $(CC) $(CFLAGS) -o $@.o -c $@.c
-@@ -180,7 +180,7 @@ getstack2: getstack.o
-
- $(MPROTSH_TESTS): body.o shlibtest.so
- $(CC) $(CFLAGS) -o $@.o -c $@.c
-- $(CC) $(LDFLAGS) $(PTHREAD) -o $@ $@.o $^
-+ $(CC) $(LDFLAGS) -o $@ $@.o $^ $(PTHREAD)
-
- # used for RANDEXEC'd binaries
- retbody.o: body.c
-@@ -189,12 +189,12 @@ retbody.o: body.c
- # build as ET_EXEC (recommended by PaX Team, not really a requirement)
- $(RET_TESTS): retbody.o
- $(CC) $(CFLAGS) $(CC_ETEXEC) -o $@.o -c $@.c
-- $(CC) $(LDFLAGS) $(LD_ETEXEC) $(PTHREAD) -o $@ $< $@.o
-+ $(CC) $(LDFLAGS) $(LD_ETEXEC) -o $@ $< $@.o $(PTHREAD)
-
- # build as ET_EXEC (not in Adamantix's Makefile)
- $(RETX_TESTS): retbody.o
- $(CC) $(CFLAGS) $(CC_ETEXEC) -o $@.o -c $@.c
-- $(CC) $(LDFLAGS) $(LD_ETEXEC) $(PTHREAD) -o $@ $< $@.o
-+ $(CC) $(LDFLAGS) $(LD_ETEXEC) -o $@ $< $@.o $(PTHREAD)
- $(PAXBIN) -SPXM $@
-
- # should also shlibbss.o and shlibdata.o be built w/ PIC?
-@@ -206,4 +206,4 @@ shlib%.so: shlib%.o
- $(CC) $(SHLDFLAGS) -shared -o $@ $<
-
- $(SHLIB_TESTS): body.o $(SHLIBS) shlibbss.o shlibdata.o
-- $(CC) $(LDFLAGS) $(PTHREAD) -o $@ body.o $@.o $(SHLIBS) $(DL)
-+ $(CC) $(LDFLAGS) -o $@ body.o $@.o $(SHLIBS) $(DL) $(PTHREAD)
diff --git a/app-admin/paxtest/files/paxtest-0.9.7_pre5-missing-includes.patch b/app-admin/paxtest/files/paxtest-0.9.7_pre5-missing-includes.patch
deleted file mode 100644
index 90da67f4492f..000000000000
--- a/app-admin/paxtest/files/paxtest-0.9.7_pre5-missing-includes.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naurp getstack.c.old getstack.c
---- getstack.c.old 2004-03-05 12:50:42.000000000 +0100
-+++ getstack.c 2009-06-29 22:52:19.036289874 +0200
-@@ -6,6 +6,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
-
- int main( int argc, char *argv[] ){
- char a;
-diff -Naurp randbody.c.old randbody.c
---- randbody.c.old 2005-06-19 16:53:40.000000000 +0200
-+++ randbody.c 2009-06-29 22:52:05.021047393 +0200
-@@ -5,6 +5,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
-
- #define COUNT (25)
-
-diff -Naurp rettofunc1.c.old rettofunc1.c
---- rettofunc1.c.old 2005-05-29 18:02:41.000000000 +0200
-+++ rettofunc1.c 2009-06-29 22:52:39.553037638 +0200
-@@ -6,6 +6,7 @@
-
- #include <stdio.h>
- #include <string.h>
-+#include <stdlib.h>
- #include "body.h"
-
- const char testname[] = "Return to function (strcpy) ";
-diff -Naurp rettofunc1x.c.old rettofunc1x.c
---- rettofunc1x.c.old 2005-05-29 18:02:47.000000000 +0200
-+++ rettofunc1x.c 2009-06-29 22:52:45.869055602 +0200
-@@ -6,6 +6,7 @@
-
- #include <stdio.h>
- #include <string.h>
-+#include <stdlib.h>
- #include "body.h"
-
- const char testname[] = "Return to function (strcpy, RANDEXEC) ";
diff --git a/app-admin/paxtest/paxtest-0.9.7_pre5.ebuild b/app-admin/paxtest/paxtest-0.9.7_pre5.ebuild
deleted file mode 100644
index bee2ab74da37..000000000000
--- a/app-admin/paxtest/paxtest-0.9.7_pre5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.7_pre5.ebuild,v 1.1 2009/06/29 22:32:39 idl0r Exp $
-
-inherit eutils multilib
-
-MY_P=${P/_/-}
-
-DESCRIPTION="PaX regression test suite"
-HOMEPAGE="http://pax.grsecurity.net"
-SRC_URI="http://grsecurity.net/~paxguy1/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-apps/chpax-0.7
- sys-apps/paxctl"
-
-# EI_PAX flags are not strip safe.
-RESTRICT="strip"
-
-S=${WORKDIR}/${MY_P}
-
-QA_EXECSTACK="usr/$(get_libdir)/${PN}/shlibdata
- usr/$(get_libdir)/${PN}/shlibbss
- usr/$(get_libdir)/${PN}/rettofunc1x
- usr/$(get_libdir)/${PN}/rettofunc2x
- usr/$(get_libdir)/${PN}/rettofunc1
- usr/$(get_libdir)/${PN}/rettofunc2
- usr/$(get_libdir)/${PN}/writetext
- usr/$(get_libdir)/${PN}/mprotshdata
- usr/$(get_libdir)/${PN}/mprotshbss
- usr/$(get_libdir)/${PN}/mprotstack
- usr/$(get_libdir)/${PN}/mprotheap
- usr/$(get_libdir)/${PN}/mprotdata
- usr/$(get_libdir)/${PN}/mprotbss
- usr/$(get_libdir)/${PN}/mprotanon
- usr/$(get_libdir)/${PN}/execstack
- usr/$(get_libdir)/${PN}/execheap
- usr/$(get_libdir)/${PN}/execdata
- usr/$(get_libdir)/${PN}/execbss
- usr/$(get_libdir)/${PN}/anonmap"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mv Makefile.psm Makefile || die
- epatch "${FILESDIR}/${P}-Makefile.patch" \
- "${FILESDIR}/${P}-missing-includes.patch"
-}
-
-src_compile() {
- emake RUNDIR=/usr/$(get_libdir)/paxtest || die
-}
-
-src_install() {
- make DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install || die
-
- newman debian/manpage.1.ex paxtest.1 || die
- dodoc ChangeLog README || die
-}
diff --git a/app-admin/paxtest/paxtest-0.9.9-r1.ebuild b/app-admin/paxtest/paxtest-0.9.9-r1.ebuild
deleted file mode 100644
index 7268d212b2d8..000000000000
--- a/app-admin/paxtest/paxtest-0.9.9-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.9-r1.ebuild,v 1.1 2010/09/18 17:11:25 blueness Exp $
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="PaX regression test suite"
-HOMEPAGE="http://pax.grsecurity.net"
-SRC_URI="http://grsecurity.net/~spender/${P}.tgz -> ${PF}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-apps/chpax-0.7
- sys-apps/paxctl"
-
-# EI_PAX flags are not strip safe.
-RESTRICT="strip"
-
-QA_EXECSTACK="usr/bin/${PN}
- usr/$(get_libdir)/${PN}/getamap
- usr/$(get_libdir)/${PN}/shlibtest2.so
- usr/$(get_libdir)/${PN}/execheap
- usr/$(get_libdir)/${PN}/mprotstack
- usr/$(get_libdir)/${PN}/mprotdata
- usr/$(get_libdir)/${PN}/mprotheap
- usr/$(get_libdir)/${PN}/randshlib
- usr/$(get_libdir)/${PN}/randmain1
- usr/$(get_libdir)/${PN}/getshlib
- usr/$(get_libdir)/${PN}/randheap2
- usr/$(get_libdir)/${PN}/rettofunc2x
- usr/$(get_libdir)/${PN}/shlibdata
- usr/$(get_libdir)/${PN}/shlibbss
- usr/$(get_libdir)/${PN}/getmain1
- usr/$(get_libdir)/${PN}/execdata
- usr/$(get_libdir)/${PN}/execstack
- usr/$(get_libdir)/${PN}/rettofunc2
- usr/$(get_libdir)/${PN}/mprotshdata
- usr/$(get_libdir)/${PN}/getstack1
- usr/$(get_libdir)/${PN}/randamap
- usr/$(get_libdir)/${PN}/rettofunc1x
- usr/$(get_libdir)/${PN}/getheap2
- usr/$(get_libdir)/${PN}/getheap1
- usr/$(get_libdir)/${PN}/randheap1
- usr/$(get_libdir)/${PN}/getstack2
- usr/$(get_libdir)/${PN}/getmain2
- usr/$(get_libdir)/${PN}/rettofunc1
- usr/$(get_libdir)/${PN}/randstack2
- usr/$(get_libdir)/${PN}/mprotshbss
- usr/$(get_libdir)/${PN}/randstack1
- usr/$(get_libdir)/${PN}/mprotanon
- usr/$(get_libdir)/${PN}/randmain2
- usr/$(get_libdir)/${PN}/writetext
- usr/$(get_libdir)/${PN}/mprotbss
- usr/$(get_libdir)/${PN}/anonmap
- usr/$(get_libdir)/${PN}/execbss
- usr/$(get_libdir)/${PN}/shlibtest.so"
-
-src_prepare() {
- mv Makefile.psm Makefile
- epatch "${FILESDIR}/${P}-Makefile.patch"
- sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
- sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
-}
-
-src_compile() {
- emake RUNDIR=/usr/$(get_libdir)/paxtest || die
-}
-
-src_install() {
- emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install || die
-
- newman debian/manpage.1.ex paxtest.1 || die
- dodoc ChangeLog README || die
-}