summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/afflib/afflib-3.6.12.ebuild')
-rw-r--r--app-forensics/afflib/afflib-3.6.12.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/app-forensics/afflib/afflib-3.6.12.ebuild b/app-forensics/afflib/afflib-3.6.12.ebuild
index 55884c6caa46..fae10a27e635 100644
--- a/app-forensics/afflib/afflib-3.6.12.ebuild
+++ b/app-forensics/afflib/afflib-3.6.12.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.12.ebuild,v 1.2 2011/07/24 18:23:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.12.ebuild,v 1.3 2011/11/24 22:16:25 radhermit Exp $
EAPI="4"
+PYTHON_DEPEND="python? 2"
-inherit eutils autotools
+inherit eutils autotools-utils python
DESCRIPTION="Library that implements the AFF image standard"
HOMEPAGE="http://www.afflib.org/"
@@ -20,11 +21,17 @@ RDEPEND="dev-libs/expat
sys-libs/zlib
fuse? ( sys-fs/fuse )
ncurses? ( sys-libs/ncurses )
- python? ( dev-lang/python )
readline? ( sys-libs/readline )
s3? ( net-misc/curl )"
DEPEND="${RDEPEND}"
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-python-module.patch
@@ -50,5 +57,5 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ remove_libtool_files all
}