summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/osmo')
-rw-r--r--app-office/osmo/ChangeLog8
-rw-r--r--app-office/osmo/files/osmo-0.2.10-libnotify-0.7.patch48
-rw-r--r--app-office/osmo/osmo-0.2.10.ebuild15
3 files changed, 64 insertions, 7 deletions
diff --git a/app-office/osmo/ChangeLog b/app-office/osmo/ChangeLog
index ffeb77441d75..5626e86e4b66 100644
--- a/app-office/osmo/ChangeLog
+++ b/app-office/osmo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/osmo
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/ChangeLog,v 1.12 2010/11/02 15:46:13 tomka Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/ChangeLog,v 1.13 2011/01/30 08:36:58 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> osmo-0.2.10.ebuild,
+ +files/osmo-0.2.10-libnotify-0.7.patch:
+ Import Fedora patch to fix building with x11-libs/libnotify >= 0.7.
02 Nov 2010; Thomas Kahle <tomka@gentoo.org> osmo-0.2.10.ebuild:
x86 stable per bug #331173
diff --git a/app-office/osmo/files/osmo-0.2.10-libnotify-0.7.patch b/app-office/osmo/files/osmo-0.2.10-libnotify-0.7.patch
new file mode 100644
index 000000000000..d626ba2f178d
--- /dev/null
+++ b/app-office/osmo/files/osmo-0.2.10-libnotify-0.7.patch
@@ -0,0 +1,48 @@
+http://pkgs.fedoraproject.org/gitweb/?p=osmo.git;a=blob_plain;f=osmo-0.2.10-libnotify-0.7.0.patch;hb=HEAD
+
+--- src/check_events.c
++++ src/check_events.c
+@@ -454,9 +454,9 @@
+ a->date = 0;
+
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
+ else
+- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
+
+ g_free (textdesc);
+ g_free (text);
+@@ -483,9 +483,6 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {
+@@ -532,9 +529,9 @@
+ a->time = -1;
+ a->date = 0;
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
+ else
+- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
+
+ notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
+@@ -545,9 +542,6 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {
diff --git a/app-office/osmo/osmo-0.2.10.ebuild b/app-office/osmo/osmo-0.2.10.ebuild
index 71819fd4f1e6..de852491e643 100644
--- a/app-office/osmo/osmo-0.2.10.ebuild
+++ b/app-office/osmo/osmo-0.2.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/osmo-0.2.10.ebuild,v 1.4 2010/11/02 15:46:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/osmo-0.2.10.ebuild,v 1.5 2011/01/30 08:36:58 ssuominen Exp $
-EAPI=2
-inherit flag-o-matic
+EAPI=3
+inherit eutils flag-o-matic
DESCRIPTION="A handy personal organizer"
HOMEPAGE="http://clayo.org/osmo/"
@@ -25,6 +25,11 @@ RDEPEND=">=x11-libs/gtk+-2.12:2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ has_version ">=x11-libs/libnotify-0.7" && epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_configure() {
append-flags -I/usr/include/libical
@@ -35,5 +40,5 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README TRANSLATORS || die
+ dodoc AUTHORS ChangeLog README TRANSLATORS
}