summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild12
-rw-r--r--app-pda/gtkpod/gtkpod-0.72.ebuild27
-rw-r--r--app-pda/malsync/malsync-2.2.0.ebuild9
-rw-r--r--app-pda/multisync/multisync-0.80-r1.ebuild46
4 files changed, 39 insertions, 55 deletions
diff --git a/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild b/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild
index aff3c4fd4000..167c7c71e19d 100644
--- a/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild
+++ b/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild
@@ -1,21 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild,v 1.5 2003/12/14 01:09:20 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot-conduits/gnome-pilot-conduits-2.0.10-r1.ebuild,v 1.6 2004/04/07 19:02:35 vapier Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Gnome Pilot Conduits"
HOMEPAGE="http://www.eskil.org/gnome-pilot/"
-IUSE=""
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc amd64 ppc"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
RDEPEND=">=gnome-base/libgnome-2.0
>=app-pda/gnome-pilot-${PVR}
>=dev-libs/libxml2-2.5"
-
DEPEND="sys-devel/gettext
dev-util/pkgconfig
${RDEPEND}"
diff --git a/app-pda/gtkpod/gtkpod-0.72.ebuild b/app-pda/gtkpod/gtkpod-0.72.ebuild
index 6b1b5ec1e42a..e0109d5b8379 100644
--- a/app-pda/gtkpod/gtkpod-0.72.ebuild
+++ b/app-pda/gtkpod/gtkpod-0.72.ebuild
@@ -1,31 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/gtkpod-0.72.ebuild,v 1.4 2004/03/04 13:24:15 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/gtkpod-0.72.ebuild,v 1.5 2004/04/07 19:03:15 vapier Exp $
-DESCRIPTION="GUI for iPod using GTK2"
+inherit eutils
+DESCRIPTION="GUI for iPod using GTK2"
HOMEPAGE="http://gtkpod.sourceforge.net/"
-
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
-mirror://sourceforge/${PN}/mp4file.c"
+ mirror://sourceforge/${PN}/mp4file.c"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="x86"
-
IUSE="mpeg4"
DEPEND=">=x11-libs/gtk+-2.0.0
- >=x11-libs/pango-1.2.1
- media-libs/libid3tag
- mpeg4? ( || ( media-libs/faad2 media-video/mpeg4ip ) )"
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-S=${WORKDIR}/${P}
+ >=x11-libs/pango-1.2.1
+ media-libs/libid3tag
+ mpeg4? ( || ( media-libs/faad2 media-video/mpeg4ip ) )"
src_unpack() {
unpack ${A}
@@ -35,11 +27,6 @@ src_unpack() {
epatch ${FILESDIR}/gtkpod-0.72-faad2.patch
}
-src_compile() {
- econf || die
- emake || die
-}
-
src_install() {
einstall || die
dodoc README
diff --git a/app-pda/malsync/malsync-2.2.0.ebuild b/app-pda/malsync/malsync-2.2.0.ebuild
index 3a711ddbc411..241a3825ee06 100644
--- a/app-pda/malsync/malsync-2.2.0.ebuild
+++ b/app-pda/malsync/malsync-2.2.0.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/malsync/malsync-2.2.0.ebuild,v 1.2 2004/03/14 13:29:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/malsync/malsync-2.2.0.ebuild,v 1.3 2004/04/07 19:03:40 vapier Exp $
-MY_P=${P/-/_}
+inherit eutils
+MY_P=${P/-/_}
DESCRIPTION="A command line tool that allows Palm Pilots to synchronize to the AvantGo.com server"
HOMEPAGE="http://www.tomw.org/malsync/"
SRC_URI="http://www.tomw.org/malsync/${MY_P}.src.tar.gz"
-SLOT="0"
LICENSE="MPL-1.0"
+SLOT="0"
KEYWORDS="~x86"
IUSE=""
@@ -27,6 +28,6 @@ src_compile() {
}
src_install() {
- dobin malsync
+ dobin malsync || die
dodoc Doc/*
}
diff --git a/app-pda/multisync/multisync-0.80-r1.ebuild b/app-pda/multisync/multisync-0.80-r1.ebuild
index eaf1f9c67c26..fcc2df06b37c 100644
--- a/app-pda/multisync/multisync-0.80-r1.ebuild
+++ b/app-pda/multisync/multisync-0.80-r1.ebuild
@@ -1,43 +1,41 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.80-r1.ebuild,v 1.6 2004/03/29 00:44:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.80-r1.ebuild,v 1.7 2004/04/07 19:04:30 vapier Exp $
+inherit eutils
+
+MY_P="${PF/r1/1}"
DESCRIPTION="Client to sync apps with WinCE or mobile devices"
HOMEPAGE="http://multisync.sourceforge.net/"
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
-MY_P="${PF/r1/1}"
SRC_URI="mirror://sourceforge/multisync/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="evo irmc opie ldap"
# evo - evolution plugin
# irmc - bluetooth/irmc/irda plugin ( local )
# opie - opie plugin ( local )
# ldap - ldap plugin - experimental
-IUSE="evo irmc opie ldap"
DEPEND="virtual/glibc
- >=gnome-base/libbonobo-2.2
- >=gnome-base/libgnome-2.2
- >=gnome-base/ORBit-0.5.17
- >=dev-libs/openssl-0.9.6j
- evo? (
- gtk2? (
- =net-mail/evolution-1.4*
- =x11-libs/gtk+-2* )
- !gtk2? (
- =net-mail/evolution-1.2*
- =x11-libs/gtk+-1* )
- )
- irmc? ( >=sys-apps/irda-utils-0.9.15
- >=net-wireless/bluez-utils-2.3
- >=dev-libs/openobex-1.0.0 )
- opie? ( >=net-misc/curl-7.10.5 )
- ldap? ( >=net-nds/openldap-2.0.27 )"
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/ORBit-0.5.17
+ >=dev-libs/openssl-0.9.6j
+ evo? (
+ gtk2? (
+ =net-mail/evolution-1.4*
+ =x11-libs/gtk+-2* )
+ !gtk2? (
+ =net-mail/evolution-1.2*
+ =x11-libs/gtk+-1* )
+ )
+ irmc? ( >=sys-apps/irda-utils-0.9.15
+ >=net-wireless/bluez-utils-2.3
+ >=dev-libs/openobex-1.0.0 )
+ opie? ( >=net-misc/curl-7.10.5 )
+ ldap? ( >=net-nds/openldap-2.0.27 )"
S=${WORKDIR}/${PF/-r1/}