summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch')
-rw-r--r--dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch113
1 files changed, 0 insertions, 113 deletions
diff --git a/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch
deleted file mode 100644
index d7df955c196c..000000000000
--- a/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- config/Make.rules.orig 2007-03-13 09:07:05.000000000 -0400
-+++ config/Make.rules 2007-03-13 09:07:13.000000000 -0400
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /$(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -125,9 +125,10 @@
- install_bindir = $(prefix)/bin
-
- install_includedir = $(prefix)/include
--install_slicedir = $(prefix)/slice
--install_schemadir = $(prefix)/schema
--install_docdir = $(prefix)/doc
-+install_slicedir = $(prefix)/share/Ice/slice
-+install_schemadir = $(prefix)/share/Ice/schema
-+install_configdir = $(prefix)/share/Ice/config
-+install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
-@@ -179,18 +180,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--ifneq ($(DB_HOME),)
-- DB_FLAGS = -I$(DB_HOME)/include
-- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
-- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
--else
-- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
-- DB_FLAGS = -I/usr/include/db45
-- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
-- else
-- DB_LIBS = -ldb_cxx
-- endif
--endif
-+DB_FLAGS = -I/usr/include/db4.5
-+DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
- EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
---- Makefile.orig 2007-03-13 09:07:20.000000000 -0400
-+++ Makefile 2007-03-13 09:08:44.000000000 -0400
-@@ -11,15 +11,15 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo slice doc
-+SUBDIRS = config src include slice doc
-
--INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
-+INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir) $(install_configdir)
-
- install::
- @if test ! -d $(prefix) ; \
- then \
- echo "Creating $(prefix)..." ; \
-- $(call mkdir,$(prefix)) ; \
-+ mkdir -p $(prefix) ; \
- fi
- ifneq ($(embedded_runpath_prefix),)
- @if test -h $(embedded_runpath_prefix) ; \
-@@ -55,8 +55,8 @@
- then \
- ( cd doc && $(MAKE) install ) || exit 1 ; \
- fi
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_docdir))
-+ $(call installdata,LICENSE,$(install_docdir))
-
- clean::
- @if test -d doc ; \
-@@ -65,4 +65,5 @@
- fi
-
- test::
-+ @( cd test && $(MAKE) ) || exit 1
- @python $(top_srcdir)/allTests.py
---- config/Makefile.orig 2007-03-13 10:05:05.000000000 -0400
-+++ config/Makefile 2007-03-13 10:05:43.000000000 -0400
-@@ -15,14 +15,9 @@
- echo ""
-
- install::
-- @if test ! -d $(prefix)/config ; \
-- then \
-- echo "Creating $(prefix)/config..." ; \
-- $(call mkdir,$(prefix)/config) ; \
-- fi
-- $(call installdata,templates.xml,$(prefix)/config)
-- $(call installdata,convertssl.py,$(prefix)/config)
-- $(call installdata,upgradeicegrid.py,$(prefix)/config)
-- $(call installdata,upgradeicestorm.py,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
-+ $(call installdata,templates.xml,$(install_configdir))
-+ $(call installdata,convertssl.py,$(install_configdir))
-+ $(call installdata,upgradeicegrid.py,$(install_configdir))
-+ $(call installdata,upgradeicestorm.py,$(install_configdir))
-+ $(call installdata,icegrid-slice.3.1.ice.gz,$(install_configdir))
-