summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/lhs2tex/ChangeLog5
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.11.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-haskell/lhs2tex/ChangeLog b/dev-haskell/lhs2tex/ChangeLog
index 77f25ff65e25..a839d9d82eb9 100644
--- a/dev-haskell/lhs2tex/ChangeLog
+++ b/dev-haskell/lhs2tex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/lhs2tex
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/ChangeLog,v 1.16 2006/10/12 17:52:08 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/ChangeLog,v 1.17 2006/10/15 18:42:43 kosmikus Exp $
+
+ 15 Oct 2006; Andres Loeh <kosmikus@gentoo.org> lhs2tex-1.11.ebuild:
+ Added a small patch to make 1.11 build with ghc-6.6.
12 Oct 2006; Duncan Coutts <dcoutts@gentoo.org> lhs2tex-1.10_pre.ebuild,
lhs2tex-1.11.ebuild:
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
index c3f88610ef9b..2fc411db722c 100644
--- a/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
+++ b/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild,v 1.6 2006/10/12 17:52:08 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild,v 1.7 2006/10/15 18:42:43 kosmikus Exp $
DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
HOMEPAGE="http://www.iai.uni-bonn.de/~loeh/lhs2tex"
@@ -15,11 +15,15 @@ S="${WORKDIR}/${P/_pre/pre}"
DEPEND=">=dev-tex/polytable-0.8.2
>=virtual/ghc-6.2.2
- !>=virtual/ghc-6.6
doc? ( dev-lang/hugs98 virtual/tetex )"
RDEPEND=">=dev-tex/polytable-0.8.2"
+src_unpack() {
+ unpack ${A}
+ sed -i "s|-package lang||" ${S}/config.mk.in || die "patch failed"
+}
+
src_compile() {
# polytable is installed separately
econf --disable-polytable || die "econf failed"