summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uthash')
-rw-r--r--dev-libs/uthash/ChangeLog9
-rw-r--r--dev-libs/uthash/uthash-1.9.6.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-libs/uthash/ChangeLog b/dev-libs/uthash/ChangeLog
index 4d8c54b2547b..b6b57da46f28 100644
--- a/dev-libs/uthash/ChangeLog
+++ b/dev-libs/uthash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/uthash
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.2 2011/11/26 16:32:08 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.3 2012/05/05 08:33:03 hwoarang Exp $
+
+*uthash-1.9.6 (05 May 2012)
+
+ 05 May 2012; Markos Chandras <hwoarang@gentoo.org> +uthash-1.9.6.ebuild:
+ version bump. Bug #414539
*uthash-1.9.5 (26 Nov 2011)
diff --git a/dev-libs/uthash/uthash-1.9.6.ebuild b/dev-libs/uthash/uthash-1.9.6.ebuild
new file mode 100644
index 000000000000..f6a1e62a6e06
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/uthash-1.9.6.ebuild,v 1.1 2012/05/05 08:33:03 hwoarang Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide,ut*}.txt || die "dodoc failed"
+}