summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/ChangeLog8
-rw-r--r--dev-python/apsw/apsw-3.7.17_p1.ebuild53
-rw-r--r--dev-python/apsw/apsw-3.8.0.2_p1.ebuild53
-rw-r--r--dev-python/apsw/apsw-3.8.0_p2.ebuild53
-rw-r--r--dev-python/apsw/apsw-3.8.1_p1.ebuild53
-rw-r--r--dev-python/apsw/apsw-3.8.2_p1.ebuild53
-rw-r--r--dev-python/apsw/apsw-3.8.3.1_p1.ebuild55
-rw-r--r--dev-python/apsw/apsw-3.8.4.1_p1.ebuild55
-rw-r--r--dev-python/apsw/apsw-3.8.4.3_p1.ebuild55
-rw-r--r--dev-python/apsw/apsw-3.8.5_p1.ebuild6
-rw-r--r--dev-python/apsw/apsw-3.8.7.1_p1.ebuild4
11 files changed, 12 insertions, 436 deletions
diff --git a/dev-python/apsw/ChangeLog b/dev-python/apsw/ChangeLog
index dc9cc617c056..4fffc49133ea 100644
--- a/dev-python/apsw/ChangeLog
+++ b/dev-python/apsw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apsw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.72 2014/11/06 06:16:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.73 2014/12/01 05:50:43 idella4 Exp $
+
+ 01 Dec 2014; Ian Delaney <idella4@gentoo.org> -apsw-3.7.17_p1.ebuild,
+ -apsw-3.8.0.2_p1.ebuild, -apsw-3.8.0_p2.ebuild, -apsw-3.8.1_p1.ebuild,
+ -apsw-3.8.2_p1.ebuild, -apsw-3.8.3.1_p1.ebuild, -apsw-3.8.4.1_p1.ebuild,
+ -apsw-3.8.4.3_p1.ebuild, apsw-3.8.5_p1.ebuild, apsw-3.8.7.1_p1.ebuild:
+ clean old python impl, minor upgrade to fix to qa issue, remove many old
*apsw-3.8.7.1_p1 (06 Nov 2014)
diff --git a/dev-python/apsw/apsw-3.7.17_p1.ebuild b/dev-python/apsw/apsw-3.7.17_p1.ebuild
deleted file mode 100644
index 9c9f1e41bc15..000000000000
--- a/dev-python/apsw/apsw-3.7.17_p1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.7.17_p1.ebuild,v 1.3 2013/09/05 18:46:50 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_P=${PN}-${PV/_p/-r}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.0.2_p1.ebuild b/dev-python/apsw/apsw-3.8.0.2_p1.ebuild
deleted file mode 100644
index fcf71b443bf4..000000000000
--- a/dev-python/apsw/apsw-3.8.0.2_p1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.0.2_p1.ebuild,v 1.1 2013/09/07 18:26:08 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_P=${PN}-${PV/_p/-r}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.0_p2.ebuild b/dev-python/apsw/apsw-3.8.0_p2.ebuild
deleted file mode 100644
index 7435f4ecf3d7..000000000000
--- a/dev-python/apsw/apsw-3.8.0_p2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.0_p2.ebuild,v 1.1 2013/08/29 05:45:40 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_P=${PN}-${PV/_p/-r}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.1_p1.ebuild b/dev-python/apsw/apsw-3.8.1_p1.ebuild
deleted file mode 100644
index bd303e85feb2..000000000000
--- a/dev-python/apsw/apsw-3.8.1_p1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.1_p1.ebuild,v 1.1 2013/11/21 03:26:19 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_P=${PN}-${PV/_p/-r}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.2_p1.ebuild b/dev-python/apsw/apsw-3.8.2_p1.ebuild
deleted file mode 100644
index ec07e4914f56..000000000000
--- a/dev-python/apsw/apsw-3.8.2_p1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.2_p1.ebuild,v 1.1 2014/01/04 10:09:52 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_P=${PN}-${PV/_p/-r}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.3.1_p1.ebuild b/dev-python/apsw/apsw-3.8.3.1_p1.ebuild
deleted file mode 100644
index 1859cd6c9099..000000000000
--- a/dev-python/apsw/apsw-3.8.3.1_p1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.3.1_p1.ebuild,v 1.1 2014/02/14 07:36:52 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_p/-r}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-HOMEPAGE="https://github.com/rogerbinns/apsw/"
-SRC_URI="https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.4.1_p1.ebuild b/dev-python/apsw/apsw-3.8.4.1_p1.ebuild
deleted file mode 100644
index bdb75c900b13..000000000000
--- a/dev-python/apsw/apsw-3.8.4.1_p1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.4.1_p1.ebuild,v 1.1 2014/04/03 06:25:39 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_p/-r}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-HOMEPAGE="https://github.com/rogerbinns/apsw/"
-SRC_URI="https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.4.3_p1.ebuild b/dev-python/apsw/apsw-3.8.4.3_p1.ebuild
deleted file mode 100644
index 0575d9cf41e0..000000000000
--- a/dev-python/apsw/apsw-3.8.4.3_p1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.4.3_p1.ebuild,v 1.2 2014/05/20 22:18:49 mrueg Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_p/-r}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-HOMEPAGE="https://github.com/rogerbinns/apsw/"
-SRC_URI="https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
- distutils-r1_python_compile --enable=load_extension
-}
-
-src_test() {
- # tests use overlapping database files
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc ; then
- dohtml -r doc/*
- fi
-}
diff --git a/dev-python/apsw/apsw-3.8.5_p1.ebuild b/dev-python/apsw/apsw-3.8.5_p1.ebuild
index 85a19afc1b15..e7c61fe60be6 100644
--- a/dev-python/apsw/apsw-3.8.5_p1.ebuild
+++ b/dev-python/apsw/apsw-3.8.5_p1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.5_p1.ebuild,v 1.1 2014/06/10 23:56:38 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.5_p1.ebuild,v 1.2 2014/12/01 05:50:43 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -29,7 +29,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
+ if ! python_is_python3; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
export CFLAGS
fi
diff --git a/dev-python/apsw/apsw-3.8.7.1_p1.ebuild b/dev-python/apsw/apsw-3.8.7.1_p1.ebuild
index 0b997ac83429..eb5b095a0ab8 100644
--- a/dev-python/apsw/apsw-3.8.7.1_p1.ebuild
+++ b/dev-python/apsw/apsw-3.8.7.1_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.7.1_p1.ebuild,v 1.1 2014/11/06 06:16:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.8.7.1_p1.ebuild,v 1.2 2014/12/01 05:50:43 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -29,7 +29,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-3.6.20.1-fix_tests.patch )
python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
+ if ! python_is_python3; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
export CFLAGS
fi