summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/ChangeLog8
-rw-r--r--dev-python/oslo-config/oslo-config-1.2.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/oslo-config/ChangeLog b/dev-python/oslo-config/ChangeLog
index 81aaa6746085..8810fc1c7616 100644
--- a/dev-python/oslo-config/ChangeLog
+++ b/dev-python/oslo-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oslo-config
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.2 2013/07/28 15:37:51 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.3 2013/09/26 00:45:40 prometheanfire Exp $
+
+*oslo-config-1.2.0 (26 Sep 2013)
+
+ 26 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +oslo-config-1.2.0.ebuild:
+ update of olso-config to 1.2.0
*oslo-config-1.1.1 (28 Jul 2013)
diff --git a/dev-python/oslo-config/oslo-config-1.2.0.ebuild b/dev-python/oslo-config/oslo-config-1.2.0.ebuild
new file mode 100644
index 000000000000..77f4cbeb7d02
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/oslo-config-1.2.0.ebuild,v 1.1 2013/09/26 00:45:40 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo configuration API supports parsing command line arguments
+and ini style configuration files"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.config/oslo.config-${PV}.tar.gz"
+S="${WORKDIR}/oslo.config-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}] )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+# This time half the doc files are missing; Do you want them?
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}