summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/argouml')
-rw-r--r--dev-util/argouml/ChangeLog9
-rw-r--r--dev-util/argouml/argouml-0.34.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-util/argouml/ChangeLog b/dev-util/argouml/ChangeLog
index 86e1e8380446..42878a82627b 100644
--- a/dev-util/argouml/ChangeLog
+++ b/dev-util/argouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/argouml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.31 2011/06/22 09:42:52 ali_bush Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.32 2012/02/03 15:16:24 fordfrog Exp $
+
+*argouml-0.34 (03 Feb 2012)
+
+ 03 Feb 2012; <fordfrog@gentoo.org> +argouml-0.34.ebuild:
+ Version bump
*argouml-0.32.2 (22 Jun 2011)
diff --git a/dev-util/argouml/argouml-0.34.ebuild b/dev-util/argouml/argouml-0.34.ebuild
new file mode 100644
index 000000000000..8f99196f7867
--- /dev/null
+++ b/dev-util/argouml/argouml-0.34.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/argouml-0.34.ebuild,v 1.1 2012/02/03 15:16:24 fordfrog Exp $
+
+EAPI="3"
+
+inherit fdo-mime java-pkg-2
+
+DESCRIPTION="modelling tool that helps you do your design using UML"
+HOMEPAGE="http://argouml.tigris.org"
+BASE_URI="http://argouml-downloads.tigris.org/nonav/${P}"
+SRC_URI="${BASE_URI}/ArgoUML-${PV}.tar.gz
+ http://argouml-downloads.tigris.org/nonav/argouml-db-1.0/dbuml-module-1.0.4.zip
+ doc? (
+ ${BASE_URI}/manual-${PV}.pdf
+ ${BASE_URI}/quickguide-${PV}.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_jarinto /opt/${PN}/lib
+ java-pkg_dojar ${P}/*.jar
+
+ java-pkg_jarinto /opt/${PN}/lib/ext
+ java-pkg_dojar ${P}/ext/*.jar release/ext/*.jar
+
+ java-pkg_dolauncher ${PN} --main org.argouml.application.Main
+
+ dodoc ${P}/README.txt || die
+
+ if use doc ; then
+ dohtml -r release/{Readme.htm,www}
+ insinto /usr/share/doc/${P}
+ doins "${DISTDIR}/manual-${PV}.pdf"
+ doins "${DISTDIR}/quickguide-${PV}.pdf"
+ fi
+
+ doicon "${FILESDIR}"/${PN}.png || die
+ make_desktop_entry ${PN} "ArgoUML" ${PN} "Graphics"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}