summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/nwmovies/ChangeLog10
-rw-r--r--games-rpg/nwmovies/nwmovies-20090223.080954.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/games-rpg/nwmovies/ChangeLog b/games-rpg/nwmovies/ChangeLog
index 2dbad368ee61..c3b0530b8db8 100644
--- a/games-rpg/nwmovies/ChangeLog
+++ b/games-rpg/nwmovies/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/nwmovies
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/ChangeLog,v 1.5 2009/01/09 13:58:11 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/ChangeLog,v 1.6 2010/01/25 01:31:32 calchan Exp $
+
+*nwmovies-20090223.080954 (25 Jan 2010)
+
+ 25 Jan 2010; Denis Dupeyron <calchan@gentoo.org>
+ +nwmovies-20090223.080954.ebuild:
+ Version bump, bug #267396.
09 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> nwmovies-0.2.ebuild:
EAPI=2; add use-based dep for games-rpg/nwn-data
diff --git a/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild b/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild
new file mode 100644
index 000000000000..5c2f8c83c5b0
--- /dev/null
+++ b/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/nwmovies-20090223.080954.ebuild,v 1.1 2010/01/25 01:31:32 calchan Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Play Neverwinter Nights movies inside the Linux client"
+HOMEPAGE="http://home.roadrunner.com/~nwmovies/"
+
+SRC_URI="${HOMEPAGE}/${PN}/${PN}-v4-public.${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=games-rpg/nwn-data-1.29-r3[videos]"
+RDEPEND="${DEPEND}
+ >=games-rpg/nwn-1.68-r4
+ media-video/binkplayer"
+
+S="${WORKDIR}"
+DESTDIR="${GAMES_PREFIX_OPT}/nwn"
+
+QA_TEXTRELS="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies.so"
+QA_WX_LOAD="opt/nwn/nwmovies.so"
+QA_EXECSTACK="opt/nwn/nwmovies.so"
+QA_DT_HASH="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies/libdis/libdisasm.so opt/nwn/nwmovies.so"
+
+src_install() {
+ exeinto "${DESTDIR}"
+ doexe nwmovies.so nwmovies.pl || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies"
+ doexe nwmovies/binklib.so || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies/libdis"
+ doexe nwmovies/libdis/libdisasm.so || die "Installation failed"
+ insinto "${DESTDIR}"
+ doins nwmovies/*.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmovies will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " \${HOME}/.nwn/\${LANG}/nwmovies.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+ elog
+ elog "If you have sound issues in NWN only when using nwmovies, then"
+ elog "you may need to properly setup /etc/asound.conf or the equivalent"
+ elog "per-user \${HOME}/.asound.conf, see comment #31 in bug #106789."
+}