summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.10.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 6202649fba19..5f275e046d1d 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.134 2013/06/04 13:06:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.135 2013/06/04 18:21:56 johu Exp $
+
+*kdepim-runtime-4.10.4 (04 Jun 2013)
+
+ 04 Jun 2013; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.10.4.ebuild:
+ Version bump KDE SC 4.10.4
04 Jun 2013; Agostino Sarubbo <ago@gentoo.org> kdepim-runtime-4.10.3.ebuild:
Stable for amd64, wrt to bug #471392
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.10.4.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.10.4.ebuild
new file mode 100644
index 000000000000..bfb2cb358ccb
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.10.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.10.4.ebuild,v 1.1 2013/06/04 18:21:56 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.9.0
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.10.0
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)')
+ x11-misc/shared-mime-info
+ google? ( >=net-libs/libkgapi-0.4.3[-oldpim] )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+# nepomuk_email_feeder moved here in 4.8
+add_blocker kdepim-common-libs 4.7.50
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package google LibKGAPI)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}