summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lash')
-rw-r--r--media-sound/lash/ChangeLog5
-rw-r--r--media-sound/lash/lash-0.5.4-r1.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/media-sound/lash/ChangeLog b/media-sound/lash/ChangeLog
index f87066395dff..376f7357f885 100644
--- a/media-sound/lash/ChangeLog
+++ b/media-sound/lash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/lash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.36 2012/09/03 16:30:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/ChangeLog,v 1.37 2012/09/03 17:05:05 ssuominen Exp $
+
+ 03 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> lash-0.5.4-r1.ebuild:
+ Install the pregenerated lash-manual.html
03 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> lash-0.5.4-r1.ebuild:
Fix building with latest texi2html wrt #422045. Use prune_libtool_files with
diff --git a/media-sound/lash/lash-0.5.4-r1.ebuild b/media-sound/lash/lash-0.5.4-r1.ebuild
index 848de4539643..74dd3783cfd3 100644
--- a/media-sound/lash/lash-0.5.4-r1.ebuild
+++ b/media-sound/lash/lash-0.5.4-r1.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4-r1.ebuild,v 1.15 2012/09/03 16:30:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4-r1.ebuild,v 1.16 2012/09/03 17:05:05 ssuominen Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
-
inherit autotools eutils python
DESCRIPTION="LASH Audio Session Handler"
HOMEPAGE="http://www.nongnu.org/lash/"
-SRC_URI="http://download.savannah.gnu.org/releases/lash/${P}.tar.gz"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -38,7 +37,7 @@ pkg_setup() {
src_prepare() {
sed -i \
- -e '/texi2html/ s/-number/&-sections/' \
+ -e '/texi2html/s:-number:&-sections:' \
docs/Makefile.am || die #422045
epatch \
@@ -49,11 +48,11 @@ src_prepare() {
}
src_configure() {
+ # 'no' could be '$(usex doc)' but we use the pregenerated lash-manual.html
export ac_cv_prog_lash_texi2html=no #422045
+ # --enable-pylash would disable it
local myconf
-
- # Yet-another-broken-configure: --enable-pylash would disable it.
use python || myconf='--disable-pylash'
econf \
@@ -66,5 +65,6 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ dohtml docs/lash-manual-html-*/lash-manual.html
+ prune_libtool_files --all # --all for _lash.la in python directory
}