summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/projectx/projectx-0.81.7.ebuild')
-rw-r--r--media-video/projectx/projectx-0.81.7.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/media-video/projectx/projectx-0.81.7.ebuild b/media-video/projectx/projectx-0.81.7.ebuild
deleted file mode 100644
index 3e1d04c6ca30..000000000000
--- a/media-video/projectx/projectx-0.81.7.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/projectx/projectx-0.81.7.ebuild,v 1.8 2005/05/04 09:30:12 luckyduck Exp $
-
-inherit java-pkg
-
-MY_PN=ProjectX
-
-DESCRIPTION="Converts, splits and demuxes DVB and other MPEG recordings"
-HOMEPAGE="http://www.lucike.info/"
-SRC_URI="http://www.lucike.info/download/software/projectx/${MY_PN}_Source_${PV}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc amd64"
-IUSE=""
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip
- >=dev-java/ant-1.4.1"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_PN}_Source"
-
-src_unpack() {
- unpack "${A}"
- cd ${S}
- # fix html help location
- sed -i "s|htmls/index.html|/usr/share/doc/${P}/html/index.html|g" src/Html.java
- # copy selfmade ant build.xml
- cp "${FILESDIR}/build.xml" .
-}
-
-src_compile() {
- local antflags="dist -DJARNAME=${P}"
- ant ${antflags} || die "compile problem"
-}
-
-src_install() {
- # create shellscript wrapper
- echo -e "#!/bin/sh\nexec \${JAVA_HOME}/bin/java -Xms32m -Xmx512m -jar /usr/share/${PN}/${P}.jar \"\$@\"" > ${MY_PN}
-
- insinto "/usr/share/${PN}"
- doins dist/lib/*.jar ac3.bin
-
- dodoc Copying *.txt
-
- java-pkg_dohtml -r htmls/
- dobin ${MY_PN}
-}
-