summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sguil-client')
-rw-r--r--net-analyzer/sguil-client/ChangeLog7
-rw-r--r--net-analyzer/sguil-client/sguil-client-0.6.1.ebuild30
2 files changed, 15 insertions, 22 deletions
diff --git a/net-analyzer/sguil-client/ChangeLog b/net-analyzer/sguil-client/ChangeLog
index 27396ee01e3a..75d9b130e09e 100644
--- a/net-analyzer/sguil-client/ChangeLog
+++ b/net-analyzer/sguil-client/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/sguil-client
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/ChangeLog,v 1.8 2009/03/08 02:54:25 cla Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/ChangeLog,v 1.9 2012/04/29 17:03:12 jer Exp $
+
+ 29 Apr 2012; Jeroen Roovers <jer@gentoo.org> sguil-client-0.6.1.ebuild:
+ Fix inherit. Remove empty DEPEND. Remove useless elog.
08 Mar 2009; Dawid Węgliński <cla@gentoo.org> sguil-client-0.6.1.ebuild:
Migration to EAPI 2, add get_libdir() fix, keyword ~amd64
diff --git a/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild b/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild
index 48d0b7e0ef55..10055bf82e5f 100644
--- a/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild
+++ b/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild,v 1.5 2009/03/08 02:54:25 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-client/sguil-client-0.6.1.ebuild,v 1.6 2012/04/29 17:03:12 jer Exp $
-EAPI="2"
-
-inherit eutils
+EAPI=4
+inherit multilib
MY_PV="${PV/_p/p}"
DESCRIPTION="GUI Console for sguil Network Security Monitoring"
@@ -15,7 +14,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ssl"
-DEPEND=""
RDEPEND="
>=dev-lang/tcl-8.3[-threads]
>=dev-lang/tk-8.3
@@ -29,17 +27,15 @@ RDEPEND="
S="${WORKDIR}/sguil-${MY_PV}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
+src_prepare() {
+ sed -i client/sguil.conf \
+ -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
-e '/^set ETHEREAL_PATH /s:/usr/sbin/ethereal:/usr/bin/wireshark:' \
-e '/^set SERVERHOST /s:demo.sguil.net:localhost:' \
-e '/^set MAILSERVER /s:mail.example.com:localhost:' \
- -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' \
- client/sguil.conf || die "sed failed"
- sed -i -e 's:^exec wish:exec wishx': \
- client/sguil.tk || die "sed failed"
+ -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' || die
+ sed -i client/sguil.tk \
+ -e 's:^exec wish:exec wishx:' || die
}
src_install() {
@@ -50,9 +46,3 @@ src_install() {
doins "${S}"/client/lib/*
dodoc doc/*
}
-
-pkg_postinst() {
- elog
- elog "You can customize your configuration by modifying /etc/sguil/sguil.conf"
- elog
-}