summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libotr/libotr-3.1.0.ebuild')
-rw-r--r--net-libs/libotr/libotr-3.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/libotr/libotr-3.1.0.ebuild b/net-libs/libotr/libotr-3.1.0.ebuild
new file mode 100644
index 000000000000..63928b864a2c
--- /dev/null
+++ b/net-libs/libotr/libotr-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libotr/libotr-3.1.0.ebuild,v 1.1 2007/08/07 02:13:17 tester Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.2.0"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ econf || die "econf failed"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}