summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog7
-rw-r--r--net-p2p/bitcoind/bitcoind-0.7.1.ebuild12
2 files changed, 8 insertions, 11 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 82924424fde4..9f858f1a352f 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.49 2012/10/29 01:46:15 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.50 2012/11/09 18:30:39 flameeyes Exp $
+
+ 09 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> bitcoind-0.7.1.ebuild:
+ Drop version-specific boost access (leverages boost-1.52.0-r1 which uses
+ system layout); this should also make sure that the multithread libraries are
+ used, unlike before, with the new layout.
29 Oct 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.6.3.ebuild,
bitcoind-0.6.4_rc3.ebuild, bitcoind-0.7.0.ebuild:
diff --git a/net-p2p/bitcoind/bitcoind-0.7.1.ebuild b/net-p2p/bitcoind/bitcoind-0.7.1.ebuild
index 4a99f45facb0..8e9ac8685f81 100644
--- a/net-p2p/bitcoind/bitcoind-0.7.1.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2010-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.1.ebuild,v 1.1 2012/10/29 01:31:05 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.1.ebuild,v 1.2 2012/11/09 18:30:38 flameeyes Exp $
EAPI="4"
@@ -20,7 +20,7 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="+eligius examples ipv6 logrotate upnp"
RDEPEND="
- >=dev-libs/boost-1.41.0
+ >=dev-libs/boost-1.41.0[threads(+)]
dev-libs/openssl[-bindist]
logrotate? (
app-admin/logrotate
@@ -49,7 +49,6 @@ src_prepare() {
src_compile() {
OPTS=()
- local BOOST_PKG BOOST_VER BOOST_INC
OPTS+=("DEBUGFLAGS=")
OPTS+=("CXXFLAGS=${CXXFLAGS}")
@@ -58,13 +57,6 @@ src_compile() {
OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
- BOOST_PKG="$(best_version 'dev-libs/boost')"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
- OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
-
if use upnp; then
OPTS+=(USE_UPNP=1)
else