summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/beagle')
-rw-r--r--sci-libs/beagle/ChangeLog13
-rw-r--r--sci-libs/beagle/beagle-3.0.3.ebuild (renamed from sci-libs/beagle/beagle-3.0.1.ebuild)7
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc43.patch89
3 files changed, 105 insertions, 4 deletions
diff --git a/sci-libs/beagle/ChangeLog b/sci-libs/beagle/ChangeLog
index ddff28a44256..e978ee3f3c69 100644
--- a/sci-libs/beagle/ChangeLog
+++ b/sci-libs/beagle/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-libs/beagle
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.8 2008/05/17 10:09:03 bicatali Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.9 2009/02/15 00:31:08 loki_val Exp $
+
+*beagle-3.0.3 (15 Feb 2009)
+
+ 15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/beagle-3.0.3-gcc43.patch, -beagle-3.0.1.ebuild,
+ +beagle-3.0.3.ebuild:
+ Bump because 3.0.1 failed to configure. Patch for bug 251629, gcc-4.3
+ compatibility. Thanks to Gene Seto <geneseto@hotmail.com> for patch and
+ bump.
17 May 2008; Sébastien Fabbro <bicatali@gentoo.org> beagle-2.2.0.ebuild,
beagle-3.0.1.ebuild:
diff --git a/sci-libs/beagle/beagle-3.0.1.ebuild b/sci-libs/beagle/beagle-3.0.3.ebuild
index c34e96c82c38..307124e4a974 100644
--- a/sci-libs/beagle/beagle-3.0.1.ebuild
+++ b/sci-libs/beagle/beagle-3.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.1.ebuild,v 1.3 2008/05/17 10:09:03 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.3.ebuild,v 1.1 2009/02/15 00:31:08 loki_val Exp $
+
+inherit eutils
IUSE="doc"
@@ -20,6 +22,7 @@ DEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.3-gcc43.patch
sed -e "s:@LIBS@:@LIBS@ -lpthread:" \
-i PACC/Threading/Makefile.in || \
die "Failed to fix threading libs makefile."
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
new file mode 100644
index 000000000000..608ce388e793
--- /dev/null
+++ b/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
@@ -0,0 +1,89 @@
+diff -rupN beagle-3.0.3b/PACC/Math/Matrix.cpp beagle-3.0.3/PACC/Math/Matrix.cpp
+--- beagle-3.0.3b/PACC/Math/Matrix.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Math/Matrix.cpp 2009-01-21 00:26:46.000000000 -0400
+@@ -40,6 +40,7 @@
+ #include <stdexcept>
+ #include <iomanip>
+ #include <cmath>
++#include <climits>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/Math/Vector.hpp beagle-3.0.3/PACC/Math/Vector.hpp
+--- beagle-3.0.3b/PACC/Math/Vector.hpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Math/Vector.hpp 2009-01-21 00:26:29.000000000 -0400
+@@ -42,6 +42,7 @@
+ #include "XML/Document.hpp"
+ #include "XML/Streamer.hpp"
+ #include <cmath>
++#include <algorithm>
+
+ namespace PACC {
+
+diff -rupN beagle-3.0.3b/PACC/Socket/Cafe.cpp beagle-3.0.3/PACC/Socket/Cafe.cpp
+--- beagle-3.0.3b/PACC/Socket/Cafe.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Socket/Cafe.cpp 2009-01-21 00:31:09.000000000 -0400
+@@ -35,6 +35,7 @@
+
+ #include "Socket/Cafe.hpp"
+ #include <iostream>
++#include <cstring>
+
+ #ifdef WIN32
+ ///////////// specifics for windows /////////////
+diff -rupN beagle-3.0.3b/PACC/Socket/Port.cpp beagle-3.0.3/PACC/Socket/Port.cpp
+--- beagle-3.0.3b/PACC/Socket/Port.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Socket/Port.cpp 2009-01-21 00:30:54.000000000 -0400
+@@ -34,6 +34,7 @@
+ */
+
+ #include "Socket/Port.hpp"
++#include <cstring>
+
+ #ifdef WIN32
+ ///////////// specifics for windows /////////////
+diff -rupN beagle-3.0.3b/PACC/Threading/Thread.cpp beagle-3.0.3/PACC/Threading/Thread.cpp
+--- beagle-3.0.3b/PACC/Threading/Thread.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Threading/Thread.cpp 2009-01-21 00:28:02.000000000 -0400
+@@ -35,6 +35,7 @@
+
+ #include "Threading/Thread.hpp"
+ #include "Util/Assert.hpp"
++#include <cstdlib>
+
+ #ifdef WIN32
+ #include <windows.h>
+diff -rupN beagle-3.0.3b/PACC/Util/SignalHandler.cpp beagle-3.0.3/PACC/Util/SignalHandler.cpp
+--- beagle-3.0.3b/PACC/Util/SignalHandler.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Util/SignalHandler.cpp 2009-01-20 23:44:20.000000000 -0400
+@@ -37,6 +37,7 @@
+ #include "Util/Assert.hpp"
+ #include <signal.h>
+ #include <stdexcept>
++#include <cstdlib>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/Util/Tokenizer.cpp beagle-3.0.3/PACC/Util/Tokenizer.cpp
+--- beagle-3.0.3b/PACC/Util/Tokenizer.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Util/Tokenizer.cpp 2009-01-20 23:44:10.000000000 -0400
+@@ -36,6 +36,8 @@
+ #include "Util/Tokenizer.hpp"
+ #include "Util/Assert.hpp"
+ #include <stdexcept>
++#include <cstring>
++#include <cstdlib>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/XML/Node.cpp beagle-3.0.3/PACC/XML/Node.cpp
+--- beagle-3.0.3b/PACC/XML/Node.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/XML/Node.cpp 2009-01-20 23:45:09.000000000 -0400
+@@ -39,6 +39,7 @@
+ #include "Util/Assert.hpp"
+ #include <sstream>
+ #include <stdexcept>
++#include <cstring>
+
+ using namespace std;
+ using namespace PACC;