summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog6
-rw-r--r--sys-apps/qingy/qingy-0.9.6-r1.ebuild12
-rw-r--r--sys-apps/qingy/qingy-0.9.6-r3.ebuild12
-rw-r--r--sys-apps/qingy/qingy-0.9.7.ebuild12
4 files changed, 20 insertions, 22 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 565c19dd2d78..1844668bbf54 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.54 2009/01/29 14:07:44 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.55 2009/02/09 09:12:12 s4t4n Exp $
+
+ 09 Feb 2009; Michele Noberasco <s4t4n@gentoo.org>
+ qingy-0.9.6-r1.ebuild, qingy-0.9.6-r3.ebuild, qingy-0.9.7.ebuild:
+ Made installation of logrotate stuf unconditional. Closes bug #258176.
29 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>
qingy-0.9.6-r1.ebuild, qingy-0.9.6-r3.ebuild, qingy-0.9.7.ebuild:
diff --git a/sys-apps/qingy/qingy-0.9.6-r1.ebuild b/sys-apps/qingy/qingy-0.9.6-r1.ebuild
index f47ba8a3f652..8ab72d6ce81b 100644
--- a/sys-apps/qingy/qingy-0.9.6-r1.ebuild
+++ b/sys-apps/qingy/qingy-0.9.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r1.ebuild,v 1.4 2009/01/29 14:07:44 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r1.ebuild,v 1.5 2009/02/09 09:12:12 s4t4n Exp $
inherit elisp-common eutils
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
+IUSE="crypt directfb emacs gpm opensslcrypt pam static X"
RDEPEND=">=sys-libs/ncurses-5.4-r6
opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
@@ -114,11 +114,9 @@ src_install()
# Alter config file so that it uses our theme
sed -i 's/theme = "default"/theme = "gentoo"/' "${D}/etc/${PN}/settings"
- # Install log rotation policy if user wants it
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
- fi
+ # Install log rotation policy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}
diff --git a/sys-apps/qingy/qingy-0.9.6-r3.ebuild b/sys-apps/qingy/qingy-0.9.6-r3.ebuild
index 45615ceabbd8..2fc6f0e83179 100644
--- a/sys-apps/qingy/qingy-0.9.6-r3.ebuild
+++ b/sys-apps/qingy/qingy-0.9.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r3.ebuild,v 1.4 2009/01/29 14:07:44 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r3.ebuild,v 1.5 2009/02/09 09:12:12 s4t4n Exp $
inherit elisp-common eutils pam
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
+IUSE="crypt directfb emacs gpm opensslcrypt pam static X"
RDEPEND=">=sys-libs/ncurses-5.4-r6
opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
@@ -117,11 +117,9 @@ src_install()
# Alter config file so that it uses our theme
sed -i 's/theme = "default"/theme = "gentoo"/' "${D}/etc/${PN}/settings"
- # Install log rotation policy if user wants it
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
- fi
+ # Install log rotation policy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
diff --git a/sys-apps/qingy/qingy-0.9.7.ebuild b/sys-apps/qingy/qingy-0.9.7.ebuild
index c7ba258250f1..201c84502012 100644
--- a/sys-apps/qingy/qingy-0.9.7.ebuild
+++ b/sys-apps/qingy/qingy-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.7.ebuild,v 1.2 2009/01/29 14:07:44 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.7.ebuild,v 1.3 2009/02/09 09:12:12 s4t4n Exp $
inherit elisp-common eutils pam
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
+IUSE="crypt directfb emacs gpm opensslcrypt pam static X"
RDEPEND=">=sys-libs/ncurses-5.4-r6
opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
@@ -117,11 +117,9 @@ src_install()
# Alter config file so that it uses our theme
sed -i 's/theme = "default"/theme = "gentoo"/' "${D}/etc/${PN}/settings"
- # Install log rotation policy if user wants it
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
- fi
+ # Install log rotation policy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"