summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/boost-m4')
-rw-r--r--sys-devel/boost-m4/ChangeLog10
-rw-r--r--sys-devel/boost-m4/boost-m4-0.3.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/sys-devel/boost-m4/ChangeLog b/sys-devel/boost-m4/ChangeLog
index b092ad0973a1..2aa99d7519b6 100644
--- a/sys-devel/boost-m4/ChangeLog
+++ b/sys-devel/boost-m4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/boost-m4
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/boost-m4/ChangeLog,v 1.6 2012/12/01 19:04:00 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/boost-m4/ChangeLog,v 1.7 2013/03/05 14:00:26 binki Exp $
+
+*boost-m4-0.3 (05 Mar 2013)
+
+ 05 Mar 2013; Nathan Phillip Brink <binki@gentoo.org> +boost-m4-0.3.ebuild:
+ Bump to boost-m4-0.3 which includes a Mac OSX -rpath LDFLAGS fix for bug
+ #460362.
01 Dec 2012; Raúl Porcel <armin76@gentoo.org> boost-m4-0.2.ebuild,
boost-m4-0.3_pre121130.ebuild:
diff --git a/sys-devel/boost-m4/boost-m4-0.3.ebuild b/sys-devel/boost-m4/boost-m4-0.3.ebuild
new file mode 100644
index 000000000000..62488bea5aee
--- /dev/null
+++ b/sys-devel/boost-m4/boost-m4-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/boost-m4/boost-m4-0.3.ebuild,v 1.1 2013/03/05 14:00:26 binki Exp $
+
+EAPI=4
+
+inherit vcs-snapshot
+
+DESCRIPTION="Another set of autoconf macros for compiling against boost"
+HOMEPAGE="http://github.com/tsuna/boost.m4"
+SRC_URI="${HOMEPAGE}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# boost.m4 has a buildsystem, but the distributer didn't use make dist
+# so we'd have to eautoreconf to use it. Also, its ./configure script
+# DEPENDs on boost. For installing one file, bootstrapping the
+# buildsystem isn't worth it.
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins build-aux/boost.m4
+
+ dodoc AUTHORS NEWS README THANKS
+}