summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog8
-rw-r--r--sys-fs/e2fsprogs/Manifest16
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.36-r3.ebuild92
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r31
4 files changed, 109 insertions, 8 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 304f0c1a2674..f94e96a2d4a7 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.48 2005/03/11 01:15:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.49 2005/03/18 02:28:55 robbat2 Exp $
+
+*e2fsprogs-1.36-r3 (17 Mar 2005)
+
+ 17 Mar 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +e2fsprogs-1.36-r3.ebuild:
+ Fix USE=static to actually build this as static again!
*e2fsprogs-1.36-r2 (10 Mar 2005)
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index 66019f4513b5..b798ef47731e 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -1,12 +1,14 @@
-MD5 69227ef9cb1469a1e974309e75914eec ChangeLog 9822
-MD5 54432110b1e54ba458f618f72d355216 e2fsprogs-1.36.ebuild 3400
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 34f9da9ce2baaac51c1ea7bcbf1a683e e2fsprogs-1.36-r2.ebuild 2625
+MD5 0e7a31e1b5f712c2f2f2b5952b2c31ee e2fsprogs-1.36-r3.ebuild 2753
+MD5 54432110b1e54ba458f618f72d355216 e2fsprogs-1.36.ebuild 3400
MD5 37cb0ccd95b17f3838109fb5c07bdd5c e2fsprogs-1.35-r1.ebuild 3377
-MD5 e86bf4d241506baff5f647cbd30ae7a0 files/digest-e2fsprogs-1.36 67
-MD5 4a7d54ccac4002d10462c40660712a72 files/e2fsprogs-1.36-sed-locale.patch 2142
+MD5 307ba62ecfabef663aa35823dcc374a6 ChangeLog 9996
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 a47cce15da0a4e01bb3cec306d9d7dbe files/e2fsprogs-1.36-makefile.patch 2910
MD5 1a896f2697b055d4b8b4139c3482ac9e files/e2fsprogs-1.32-mk_cmds-cosmetic.patch 316
-MD5 e86bf4d241506baff5f647cbd30ae7a0 files/digest-e2fsprogs-1.36-r2 67
MD5 f079047f6885f762f6fa838b55236cb2 files/e2fsprogs-sed-locale.patch 5989
-MD5 a47cce15da0a4e01bb3cec306d9d7dbe files/e2fsprogs-1.36-makefile.patch 2910
+MD5 e86bf4d241506baff5f647cbd30ae7a0 files/digest-e2fsprogs-1.36 67
+MD5 4a7d54ccac4002d10462c40660712a72 files/e2fsprogs-1.36-sed-locale.patch 2142
MD5 3d9735f2397680a4978124f6805219ae files/digest-e2fsprogs-1.35-r1 67
+MD5 e86bf4d241506baff5f647cbd30ae7a0 files/digest-e2fsprogs-1.36-r2 67
+MD5 e86bf4d241506baff5f647cbd30ae7a0 files/digest-e2fsprogs-1.36-r3 67
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.36-r3.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.36-r3.ebuild
new file mode 100644
index 000000000000..1cc445d7d512
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.36-r3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.36-r3.ebuild,v 1.1 2005/03/18 02:28:55 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static diet"
+
+RDEPEND="diet? ( dev-libs/dietlibc )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix a cosmetic error in mk_cmds's help output.
+ epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
+ # Patch to make the configure and sed scripts more friendly to,
+ # for example, the Estonian locale
+ epatch "${FILESDIR}"/${P}-sed-locale.patch
+ chmod u+w po/*.po # Userpriv fix #27348
+ # Clean up makefile to suck less
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ # kernel headers use the same defines as e2fsprogs and can cause issues #48829
+ sed -i \
+ -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
+ $(grep -rl CONFIG_JBD_DEBUG *) \
+ || die "sed jbd debug failed"
+
+ # building e2fsprogs on sparc results in silo breaking
+ [[ ${ARCH} == "sparc" ]] && filter-flags -fstack-protector
+
+ # Keep the package from doing silly things
+ export LDCONFIG=/bin/true
+ export CC=$(tc-getCC)
+ export STRIP=/bin/true
+}
+
+src_compile() {
+ local myconf
+ use diet && myconf="${myconf} --with-diet-libc"
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ $(use_enable !static elf-shlibs) \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !static dynamic-e2fsck) \
+ $(use_enable nls) \
+ ${myconf} || die
+ # Parallel make sometimes fails
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog README RELEASE-NOTES SHLIBS
+ docinto e2fsck
+ dodoc e2fsck/ChangeLog e2fsck/CHANGES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir) /usr/$(get_libdir)
+ dolib.a lib/*.a || die "dolib.a"
+ local x
+ # if we built as static, none of this exists
+ if ! useq static; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
+ cd "${D}"/$(get_libdir)
+ for x in *.so ; do
+ [ -f "${x}" ] && gen_usr_ldscript ${x} || die "gen ldscript ${x}"
+ done
+ fi
+
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ # Install template awk files for compile_et
+ insinto /usr/share/et
+ doins "${S}"/lib/et/*.awk || die "doins et awk"
+ insinto /usr/share/ss
+ doins "${S}"/lib/ss/*.awk || die "doins ss awk"
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r3 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r3
new file mode 100644
index 000000000000..b9df1ce9da18
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r3
@@ -0,0 +1 @@
+MD5 1804ee96b76e5e7113fe3cecd6fe582b e2fsprogs-1.36.tar.gz 3264042