summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/ecore/ecore-1.0.0.20040201_pre4.ebuild35
-rw-r--r--x11-libs/ecore/files/digest-ecore-1.0.0.20040201_pre41
-rw-r--r--x11-libs/esmart/esmart-0.0.2.20040201.ebuild13
-rw-r--r--x11-libs/esmart/files/digest-esmart-0.0.2.200402011
-rw-r--r--x11-libs/evas/evas-1.0.0.20040201_pre12.ebuild69
-rw-r--r--x11-libs/evas/files/digest-evas-1.0.0.20040201_pre121
-rw-r--r--x11-libs/ewl/ewl-0.0.3.20040201.ebuild16
-rw-r--r--x11-libs/ewl/files/digest-ewl-0.0.3.200402011
8 files changed, 137 insertions, 0 deletions
diff --git a/x11-libs/ecore/ecore-1.0.0.20040201_pre4.ebuild b/x11-libs/ecore/ecore-1.0.0.20040201_pre4.ebuild
new file mode 100644
index 000000000000..d301e9f5967b
--- /dev/null
+++ b/x11-libs/ecore/ecore-1.0.0.20040201_pre4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-1.0.0.20040201_pre4.ebuild,v 1.1 2004/02/01 20:25:46 vapier Exp $
+
+inherit enlightenment
+
+DESCRIPTION="core event abstraction layer and X abstraction layer (nice convenience library)"
+HOMEPAGE="http://www.enlightenment.org/pages/ecore.html"
+
+IUSE="${IUSE} opengl fbcon X"
+
+DEPEND="${DEPEND}
+ >=x11-libs/evas-1.0.0.20040117_pre12
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ export MY_ECONF="
+ `use_enable X ecore-x` \
+ --enable-ecore-job \
+ `use_enable fbcon ecore-fb` \
+ --enable-ecore-evas \
+ `use_enable opengl ecore-evas-gl` \
+ `use_enable fbcon ecore-evas-fb` \
+ --enable-ecore-con \
+ --enable-ecore-ipc \
+ --enable-ecore-txt \
+ --enable-ecore-config
+ "
+
+ # http://xcomputerman.com/bugs/view_bug_page.php?f_id=23
+ export MAKEOPTS="${MAKEOPTS} -j1"
+
+ enlightenment_src_compile
+}
diff --git a/x11-libs/ecore/files/digest-ecore-1.0.0.20040201_pre4 b/x11-libs/ecore/files/digest-ecore-1.0.0.20040201_pre4
new file mode 100644
index 000000000000..64ec554b0cb8
--- /dev/null
+++ b/x11-libs/ecore/files/digest-ecore-1.0.0.20040201_pre4
@@ -0,0 +1 @@
+MD5 3db0a34a90e3c80a7fbad4f11a68c951 ecore-1.0.0.20040201_pre4.tar.bz2 3472075
diff --git a/x11-libs/esmart/esmart-0.0.2.20040201.ebuild b/x11-libs/esmart/esmart-0.0.2.20040201.ebuild
new file mode 100644
index 000000000000..25c9b6a1ba2d
--- /dev/null
+++ b/x11-libs/esmart/esmart-0.0.2.20040201.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/esmart/esmart-0.0.2.20040201.ebuild,v 1.1 2004/02/01 20:26:54 vapier Exp $
+
+inherit enlightenment flag-o-matic
+
+DESCRIPTION="A collection of evas smart objects"
+HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
+
+DEPEND=">=x11-libs/evas-1.0.0.20031013_pre12
+ >=x11-libs/ecore-1.0.0.20031213_pre4
+ >=media-libs/epsilon-0.0.2.20031213
+ >=media-libs/imlib2-1.1.0"
diff --git a/x11-libs/esmart/files/digest-esmart-0.0.2.20040201 b/x11-libs/esmart/files/digest-esmart-0.0.2.20040201
new file mode 100644
index 000000000000..96ca4fdbb7a8
--- /dev/null
+++ b/x11-libs/esmart/files/digest-esmart-0.0.2.20040201
@@ -0,0 +1 @@
+MD5 387cb63da44ed107d0d1098881fe0096 esmart-0.0.2.20040201.tar.bz2 70423
diff --git a/x11-libs/evas/evas-1.0.0.20040201_pre12.ebuild b/x11-libs/evas/evas-1.0.0.20040201_pre12.ebuild
new file mode 100644
index 000000000000..d5a040e0a500
--- /dev/null
+++ b/x11-libs/evas/evas-1.0.0.20040201_pre12.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20040201_pre12.ebuild,v 1.1 2004/02/01 20:27:33 vapier Exp $
+
+inherit enlightenment flag-o-matic
+
+DESCRIPTION="hardware-accelerated canvas API"
+HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
+
+IUSE="${IUSE} X mmx opengl jpeg png directfb fbcon"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.1.0
+ >=dev-libs/eet-0.9.0.20040117
+ >=dev-db/edb-1.0.4.20031013
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ dev-util/pkgconfig"
+
+src_compile() {
+ # other *very* fun options:
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-mmx enable mmx code
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+ export MY_ECONF="
+ `use_enable mmx cpu-mmx` \
+ `use_enable sse cpu-mmx` \
+ `use_enable sse cpu-sse` \
+ `use_enable X software-x11` \
+ `use_enable opengl gl-x11` \
+ `use_enable directfb` \
+ `use_enable fbcon fb` \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-444 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-16-rgb-rot-270 \
+ --enable-convert-16-rgb-rot-90 \
+ --enable-convert-24-rgb-888 \
+ --enable-convert-24-bgr-888 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ --enable-convert-32-rgb-rot-270 \
+ --enable-convert-32-rgb-rot-90 \
+ `use_enable png image-loader-png` \
+ `use_enable jpeg image-loader-jpeg`
+ "
+ enlightenment_src_compile
+}
diff --git a/x11-libs/evas/files/digest-evas-1.0.0.20040201_pre12 b/x11-libs/evas/files/digest-evas-1.0.0.20040201_pre12
new file mode 100644
index 000000000000..8443f16ea38a
--- /dev/null
+++ b/x11-libs/evas/files/digest-evas-1.0.0.20040201_pre12
@@ -0,0 +1 @@
+MD5 ccb9669f182da72c8c64512eaa6d951e evas-1.0.0.20040201_pre12.tar.bz2 4218087
diff --git a/x11-libs/ewl/ewl-0.0.3.20040201.ebuild b/x11-libs/ewl/ewl-0.0.3.20040201.ebuild
new file mode 100644
index 000000000000..d4f8c36e0dfe
--- /dev/null
+++ b/x11-libs/ewl/ewl-0.0.3.20040201.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ewl/ewl-0.0.3.20040201.ebuild,v 1.1 2004/02/01 20:28:13 vapier Exp $
+
+EHACKAUTOGEN=y
+inherit enlightenment flag-o-matic
+
+DESCRIPTION="simple-to-use general purpose widget library"
+HOMEPAGE="http://www.enlightenment.org/pages/ewl.html"
+
+DEPEND=">=media-libs/edje-0.0.1.20040201
+ >=dev-db/edb-1.0.4.20031013
+ >=x11-libs/evas-1.0.0.20031020_pre12
+ >=x11-libs/ecore-1.0.0.20031213_pre4
+ >=dev-libs/ewd-0.0.1.20031013
+ >=media-libs/etox-0.0.2.20031013"
diff --git a/x11-libs/ewl/files/digest-ewl-0.0.3.20040201 b/x11-libs/ewl/files/digest-ewl-0.0.3.20040201
new file mode 100644
index 000000000000..4baa2f4f7d10
--- /dev/null
+++ b/x11-libs/ewl/files/digest-ewl-0.0.3.20040201
@@ -0,0 +1 @@
+MD5 7681397cb93492110aa09a91f94a060c ewl-0.0.3.20040201.tar.bz2 626215