summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/x2vnc/x2vnc-1.6.ebuild')
-rw-r--r--x11-misc/x2vnc/x2vnc-1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.6.ebuild b/x11-misc/x2vnc/x2vnc-1.6.ebuild
new file mode 100644
index 000000000000..a76d132fbc28
--- /dev/null
+++ b/x11-misc/x2vnc/x2vnc-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.6.ebuild,v 1.1 2003/11/27 06:55:29 phosphan Exp $
+
+DESCRIPTION="Control a remote computer running VNC from X"
+SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc"
+
+DEPEND="virtual/x11
+ tcltk? ( dev-tcltk/expect )"
+
+IUSE="tcltk"
+
+src_compile() {
+ econf
+ emake || die "make failed"
+}
+
+src_install () {
+
+ dodir /usr/share
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+
+ if [ `use tcltk` ]
+ then
+ dobin contrib/tkx2vnc
+ fi
+
+ dodoc ChangeLog README
+}
+
+