From fd3598943f1cf80e7a050d3baf212024206a2dea Mon Sep 17 00:00:00 2001
From: Ian Delaney <idella4@gentoo.org>
Date: Sun, 8 Sep 2013 14:51:37 +0000
Subject: revbump -EAPI 5, add invocation of tests

(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
---
 dev-perl/SpeedyCGI/ChangeLog                |  7 ++++-
 dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild | 42 +++++++++++++++++++++++++++++
 2 files changed, 48 insertions(+), 1 deletion(-)
 create mode 100644 dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild

diff --git a/dev-perl/SpeedyCGI/ChangeLog b/dev-perl/SpeedyCGI/ChangeLog
index 1102fddafcc4..51ee6387e1d7 100644
--- a/dev-perl/SpeedyCGI/ChangeLog
+++ b/dev-perl/SpeedyCGI/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for dev-perl/SpeedyCGI
 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/ChangeLog,v 1.17 2013/02/16 12:34:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/ChangeLog,v 1.18 2013/09/08 14:51:37 idella4 Exp $
+
+*SpeedyCGI-2.22-r3 (08 Sep 2013)
+
+  08 Sep 2013; Ian Delaney <idella4@gentoo.org> +SpeedyCGI-2.22-r3.ebuild:
+  revbump -EAPI 5, add invocation of tests
 
   16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
   Cleanup due bug #96436
diff --git a/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild b/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild
new file mode 100644
index 000000000000..b3a18789c6db
--- /dev/null
+++ b/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SpeedyCGI/SpeedyCGI-2.22-r3.ebuild,v 1.1 2013/09/08 14:51:36 idella4 Exp $
+
+EAPI=5
+inherit perl-module
+
+DESCRIPTION="Speed up perl scripts by running them persistently"
+HOMEPAGE="http://daemoninc.com/SpeedyCGI/"
+SRC_URI="http://daemoninc.com/SpeedyCGI/CGI-${P}.tar.gz
+	http://oss.oetiker.ch/smokeping/pub/speedy-error.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/CGI-${P}
+
+PATCHES=( "${DISTDIR}/speedy-error.patch"
+"${FILESDIR}/${P}-makefile-manpage.patch"
+"${FILESDIR}/${P}-empty-param.patch"
+"${FILESDIR}/${P}-strerror.patch"
+"${FILESDIR}/${P}-apache-docs.patch"
+"${FILESDIR}/${P}-apache2.2.patch"
+"${FILESDIR}/${P}-strip-backend-libs.patch"
+"${FILESDIR}/${P}-test-timeout.patch"
+"${FILESDIR}/${P}-speedy_unsafe_putenv.patch"
+"${FILESDIR}/${P}-perl5.10.patch"
+"${FILESDIR}/${P}-perl_sys_init.patch"
+"${FILESDIR}/${P}-uninit-crash.patch"
+"${FILESDIR}/${P}-big-socket-buffers.patch"
+"${FILESDIR}/${P}-ldflags.patch"
+"${FILESDIR}/${P}-parallel-build.patch"
+)
+
+# Actually fails 1 test
+SRC_TEST="do parallel"
+MAKEOPTS="${MAKEOPTS} -j1" #348065
-- 
cgit v1.2.3-65-gdbad