From cb7e7b72efd1efb3c3448c1bdbf080a9f6f1e70b Mon Sep 17 00:00:00 2001
From: Robert Coie <rac@gentoo.org>
Date: Wed, 4 Jun 2003 00:21:29 +0000
Subject: new ebuild version, masked for testing

---
 dev-lang/perl/ChangeLog                   |   8 +-
 dev-lang/perl/Manifest                    |   4 +-
 dev-lang/perl/files/digest-perl-5.8.0-r11 |   3 +
 dev-lang/perl/perl-5.8.0-r11.ebuild       | 310 ++++++++++++++++++++++++++++++
 4 files changed, 323 insertions(+), 2 deletions(-)
 create mode 100644 dev-lang/perl/files/digest-perl-5.8.0-r11
 create mode 100644 dev-lang/perl/perl-5.8.0-r11.ebuild

(limited to 'dev-lang')

diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index c84733a46883..b22710bc3364 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/perl
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.15 2003/06/02 07:33:46 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.16 2003/06/04 00:21:23 rac Exp $
+
+*perl-5.8.0-r11 (03 Jun 2003)
+
+  03 Jun 2003; <rac@gentoo.org> perl-5.8.0-r11.ebuild:
+  Clean out libperl bits from ebuild. Grab newer version of Safe.pm from CPAN
+  for security reasons, DB_File for db 4.1 compatibility.
 
 *perl-5.6.1-r12 (02 Jun 2003)
 
diff --git a/dev-lang/perl/Manifest b/dev-lang/perl/Manifest
index baed52fe93bd..8ff390670926 100644
--- a/dev-lang/perl/Manifest
+++ b/dev-lang/perl/Manifest
@@ -2,7 +2,8 @@ MD5 4d2f1d1d20f2c6b2562caa1e2264b056 perl-5.6.1-r12.ebuild 7177
 MD5 227961c744001cba740b19e6cf3977fb perl-5.8.0-r10.ebuild 13793
 MD5 a3f762c7ce784283e55c6e6727aa99dd perl-5.8.0-r9.ebuild 13571
 MD5 36e6b9097f119057a2e82e6d4bf10a32 perl-5.6.1-r11.ebuild 6301
-MD5 61c50979a2b042d9133d65107b9623e5 ChangeLog 15504
+MD5 5b6edc9efd236bc90260a51560ca8032 ChangeLog 15727
+MD5 2f27e92b9b5699739c85e501c85f1ef1 perl-5.8.0-r11.ebuild 9686
 MD5 f5dbb33ce4fa58feff7201667ee245a8 perl-5.6.1-r10.ebuild 6844
 MD5 060e9f10466fdc1268c75a7cf4dcbc7c files/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch 446
 MD5 4e49da394d326bcb744c7990bd27d6ac files/perl-5.8.0-perldoc-emptydirs.patch 461
@@ -13,6 +14,7 @@ MD5 28fe3868fd4e47ca609f7af6156c94ea files/5.6.1-op-test-fix.diff 503
 MD5 b8480b2ccbf7d5a7fe543b9e6f8dbc14 files/libperl_rebuilder 10260
 MD5 ea9bf02b28e73e19dc85eb07f2347460 files/5.6.1-builtin-fixup.diff 777
 MD5 9810be5a789a6d0bde088fef8fb261a4 files/digest-perl-5.8.0-r10 861
+MD5 5c83a2e6f630182b708d39c7de034075 files/digest-perl-5.8.0-r11 188
 MD5 4e99f7529e149661372283c981cf17ff files/perl-5.8.0-prelink-lpthread.patch 476
 MD5 803b7c028f59008ea1e6d577e5c0bab0 files/stat.t 8884
 MD5 cc61dca6d96347b5d93cfdde1514feb4 files/digest-perl-5.8.0-r9 860
diff --git a/dev-lang/perl/files/digest-perl-5.8.0-r11 b/dev-lang/perl/files/digest-perl-5.8.0-r11
new file mode 100644
index 000000000000..8303b880706d
--- /dev/null
+++ b/dev-lang/perl/files/digest-perl-5.8.0-r11
@@ -0,0 +1,3 @@
+MD5 d9bdb180620306023fd35901a2878b62 perl-5.8.0.tar.gz 11023084
+MD5 306033319ec016cbec2ff4f3238f3566 DB_File-1.806.tar.gz 80078
+MD5 1dbc4728cea6c662d03ea4a0863859a5 Safe-2.09.tar.gz 11465
diff --git a/dev-lang/perl/perl-5.8.0-r11.ebuild b/dev-lang/perl/perl-5.8.0-r11.ebuild
new file mode 100644
index 000000000000..f7c6cbcbcb9d
--- /dev/null
+++ b/dev-lang/perl/perl-5.8.0-r11.ebuild
@@ -0,0 +1,310 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.0-r11.ebuild,v 1.1 2003/06/04 00:21:23 rac Exp $
+
+IUSE="berkdb doc gdbm threads"
+
+inherit eutils flag-o-matic 
+
+# Perl has problems compiling with -Os in your flags
+replace-flags "-Os" "-O2"
+# This flag makes compiling crash in interesting ways
+filter-flags "-malign-double"
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
+MY_P="${P/lib}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+DB_FILE_VERSION="1.806"
+SAFE_VERSION="2.09"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz
+	ftp://ftp.perl.org/pub/CPAN/modules/by-module/DB_File/DB_File-${DB_FILE_VERSION}.tar.gz
+	ftp://ftp.perl.org/pub/CPAN/modules/by-module/Safe/Safe-${SAFE_VERSION}.tar.gz"
+SLOT="0"
+LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~mips ~hppa"
+
+DEPEND="sys-apps/groff
+	berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 )
+	gdbm? ( >=sys-libs/gdbm-1.8.0 )
+	>=sys-apps/portage-2.0.45-r5
+	=sys-devel/libperl-${PV}*"
+
+RDEPEND="berkdb? ( sys-libs/db )
+	gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+pkg_setup() {
+	# I think this should rather be displayed if you *have* 'threads'
+	# in USE if it could break things ...
+	if [ -n "`use threads`" ]
+	then
+		ewarn ""
+		ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
+		ewarn "threading enabled."
+		ewarn "Threading is not supported by all applications "
+		ewarn "that compile against perl. You use threading at "
+		ewarn "your own discretion. "
+		ewarn ""
+		sleep 10
+	else
+		ewarn ""
+		ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
+		ewarn "threading enabled , you must restart this emerge"
+		ewarn "with USE=threads emerge...."
+		ewarn "Threading is not supported by all applications "
+		ewarn "that compile against perl. You use threading at "
+		ewarn "your own discretion. "
+		ewarn ""
+	fi
+
+	if [ ! -f /usr/lib/${LIBPERL} ]
+	then
+		# Make sure we have libperl installed ...
+		eerror "Cannot find /usr/lib/${LIBPERL}!  Make sure that you"
+		eerror "have sys-libs/libperl installed properly ..."
+		die "Cannot find /usr/lib/${LIBPERL}!"
+	fi
+}
+
+src_unpack() {
+
+	unpack ${A}
+
+	# Fix the definition of 'int sockatmark(int);' in perl.h to have __THROW.
+	# This fixes bug #12605.
+	# <azarah@gentoo.org> (28 Dec 2002).
+	cd ${S}; epatch ${FILESDIR}/${P}-sockatmark-should-__THROW.patch
+
+	# Get -lpthread linked before -lc.  This is needed
+	# when using glibc >= 2.3, or else runtime signal
+	# handling breaks.  Fixes bug #14380.
+	# <rac@gentoo.org> (14 Feb 2003)
+	cd ${S}; epatch ${FILESDIR}/${P}-prelink-lpthread.patch
+
+	# Patch perldoc to not abort when it attempts to search
+	# nonexistent directories; fixes bug #16589.
+	# <rac@gentoo.org> (28 Feb 2003)
+	cd ${S}; epatch ${FILESDIR}/${P}-perldoc-emptydirs.patch
+
+	# to allow building with db4, must replace the DB_File in the core
+	# with a newer one from CPAN.
+
+	einfo "Replacing core DB_File with newer version ${DB_FILE_VERSION}"
+	rm -rf ${S}/ext/DB_File
+	cp -R ${WORKDIR}/DB_File-${DB_FILE_VERSION} ${S}/ext/DB_File
+
+	# there is a security problem in the Safe.pm version in the core.
+	einfo "Replacing core Safe.pm with newer version ${SAFE_VERSION}"
+	chmod +w ${S}/ext/Opcode/Safe.pm
+	cp ${WORKDIR}/Safe-${SAFE_VERSION}/Safe.pm ${S}/ext/Opcode/
+}
+
+src_compile() {
+
+	export LC_ALL="C"
+	local myconf=""
+	
+	if [ "`use threads`" ]
+	then
+		einfo "using threads"
+		mythreading="-multi"
+		myconf="-Dusethreads ${myconf}"
+		myarch="${CHOST%%-*}-linux-thread"
+	else
+		myarch="${CHOST%%-*}-linux"
+	fi
+
+	if [ "`use gdbm`" ]
+	then
+		myconf="${myconf} -Di_gdbm"
+	fi
+	if [ "`use berkdb`" ]
+	then
+		myconf="${myconf} -Di_db -Di_ndbm"
+	else
+		myconf="${myconf} -Ui_db -Ui_ndbm"
+	fi
+	if [ "`use sparc`" ]
+	then
+		myconf="${myconf} -Ud_longdbl"
+	fi
+	if [ "`use sparc64`" ]
+	then
+		myconf="${myconf} -Ud_longdbl"
+	fi
+	
+cat > config.over <<EOF
+installprefix=${D}/usr
+installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
+installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
+installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/share/share/!/share/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/share/share/!/share/!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/usr/man/!/usr/share/man/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/usr/man/!/usr/share/man/!"\`
+man1ext=1
+man3ext=3pm
+installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
+installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
+installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
+installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
+EOF
+	sleep 10
+	sh Configure -des \
+		-Darchname="${myarch}" \
+		-Dcc="${CC:-gcc}" \
+		-Dprefix='/usr' \
+		-Dvendorprefix='/usr' \
+		-Dsiteprefix='/usr' \
+		-Dlocincpth=' ' \
+		-Doptimize="${CFLAGS}" \
+		-Duselargefiles \
+		-Dd_dosuid \
+		-Dd_semctl_semun \
+		-Dscriptdir=/usr/bin \
+		-Dman3ext='3pm' \
+		-Dcf_by='Gentoo' \
+		-Ud_csh \
+		${myconf} || die "Unable to configure"
+			
+	MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
+	
+	emake -i test CCDLFLAGS=
+}
+
+src_install() {
+	
+	export LC_ALL="C"
+	
+	# Need to do this, else apps do not link to dynamic version of
+	# the library ...
+	local coredir="/usr/lib/perl5/${PV}/${myarch}${mythreading}/CORE"
+	dodir ${coredir}
+	dosym ../../../../${LIBPERL} ${coredir}/${LIBPERL}
+	dosym ../../../../${LIBPERL} ${coredir}/libperl.so.${PERLSLOT}
+	dosym ../../../../${LIBPERL} ${coredir}/libperl.so
+		
+	# Fix for "stupid" modules and programs
+	dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
+
+	make DESTDIR="${D}" \
+		INSTALLMAN1DIR="${D}/usr/share/man/man1" \
+		INSTALLMAN3DIR="${D}/usr/share/man/man3" \
+		install || die "Unable to make install"
+
+	cp -f utils/h2ph utils/h2ph_patched
+	epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
+
+	LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+		-a -d ${D}/usr/lib/perl5/${PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+	# This is to fix a missing c flag for backwards compat
+	for i in `find ${D}/usr/lib/perl5 -iname "Config.pm"`;do
+		sed -e "s:ccflags=':ccflags='-DPERL5 :" \
+		    -e "s:cppflags=':cppflags='-DPERL5 :" \
+			${i} > ${i}.new &&\
+			mv ${i}.new ${i} || die "Sed failed"
+	done
+
+	# A poor fix for the miniperl issues
+	dosed 's:./miniperl:/usr/bin/perl:' /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+	fperms 0444 /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+	dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+	fperms 0755 /usr/bin/xsubpp
+
+	./perl installman \
+		--man1dir="${D}/usr/share/man/man1" --man1ext='1' \
+		--man3dir="${D}/usr/share/man/man3" --man3ext='3'
+
+	# This removes ${D} from Config.pm and .packlist
+	for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do 
+		einfo "Removing ${D} from ${i}..."
+		sed -e "s:${D}::" ${i} > ${i}.new &&\
+			mv ${i}.new ${i} || die "Sed failed"
+	done
+	
+	dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+	if [ -n "`use doc`" ]
+	then
+		# HTML Documentation
+		# We expect errors, warnings, and such with the following. 
+
+		dodir /usr/share/doc/${PF}/html
+		./perl installhtml \
+			--podroot='.' \
+			--podpath='lib:ext:pod:vms' \
+			--recurse \
+			--htmldir="${D}/usr/share/doc/${PF}/html" \
+			--libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+	fi
+}
+
+pkg_postinst() {
+
+	# Make sure we do not have stale/invalid libperl.so 's ...
+	if [ -f "${ROOT}usr/lib/libperl.so" -a ! -L "${ROOT}usr/lib/libperl.so" ]
+	then
+		mv -f ${ROOT}usr/lib/libperl.so ${ROOT}usr/lib/libperl.so.old
+	fi
+
+	local perllib="`readlink -f ${ROOT}usr/lib/libperl.so | sed -e 's:^.*/::'`"
+
+	# If we are installing perl, we need the /usr/lib/libperl.so symlink to
+	# point to the version of perl we are running, else builing something
+	# against libperl.so will break ...
+	if [ "${perllib}" != "${LIBPERL}" ]
+	then
+		# Delete stale symlinks
+		rm -f ${ROOT}usr/lib/libperl.so
+		rm -f ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+		# Regenerate libperl.so.${PERLSLOT}
+		ln -snf ${LIBPERL} ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+		# Create libperl.so (we use the *soname* versioned lib here ..)
+		ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+	fi
+		
+	if [ "${ROOT}" = "/" ]
+	then
+		ebegin "Converting C header files to the corresponding Perl format"
+		cd /usr/include; h2ph *.h sys/*.h
+	fi
+
+	eerror ""
+	eerror "If this is an upgrade to a perl 5.6.1 system,"
+	eerror "~OR~ an upgrade to a previous Gentoo release"
+	eerror "of perl 5.8.0, prior to -r8 "
+	eerror "you may need to recompile applications that"
+	eerror "were emerged against the old libperl.so"
+	eerror ""
+	eerror "${FILESDIR}/libperl_rebuilder "
+	eerror "is provided to assist with this. "
+	eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+	eerror "Part of the rebuilding of applications compiled against "
+	eerror "your old libperl involves temporarily unmerging"
+	eerror "them - interruptions could leave you with unmerged"
+	eerror "packages before they can be remerged."
+	eerror ""
+	eerror "If you have run the rebuilder and a package still gives"
+	eerror "you trouble, and re-emerging it fails to correct"
+	eerror "the problem, please check http://bugs.gentoo.org/"
+	eerror "for more information or to report a bug."
+	eerror ""
+	eerror ""
+}
+
+
-- 
cgit v1.2.3-65-gdbad