From b52eafa441e7dbb11a4ff3d9a5516fbab5727488 Mon Sep 17 00:00:00 2001
From: Sven Wegener <swegener@gentoo.org>
Date: Mon, 3 Aug 2009 19:34:12 +0000
Subject: Version bump. (Portage version: 2.2_rc33/cvs/Linux x86_64)

---
 net-dns/pdns-recursor/ChangeLog                    |  9 +++-
 .../pdns-recursor-3.1.7.1-error-message.patch      | 11 +++++
 net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild | 57 ++++++++++++++++++++++
 3 files changed, 76 insertions(+), 1 deletion(-)
 create mode 100644 net-dns/pdns-recursor/files/pdns-recursor-3.1.7.1-error-message.patch
 create mode 100644 net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild

(limited to 'net-dns')

diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 2b65a4443c72..de1080207db7 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for net-dns/pdns-recursor
 # Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.29 2009/07/04 18:12:37 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.30 2009/08/03 19:34:12 swegener Exp $
+
+*pdns-recursor-3.1.7.1 (03 Aug 2009)
+
+  03 Aug 2009; Sven Wegener <swegener@gentoo.org>
+  +pdns-recursor-3.1.7.1.ebuild,
+  +files/pdns-recursor-3.1.7.1-error-message.patch:
+  Version bump.
 
   04 Jul 2009; Sven Wegener <swegener@gentoo.org>
   -pdns-recursor-3.1.6.ebuild, -files/pdns-recursor-3.1.6-gcc-4.3.patch:
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-3.1.7.1-error-message.patch b/net-dns/pdns-recursor/files/pdns-recursor-3.1.7.1-error-message.patch
new file mode 100644
index 000000000000..ed1f2285c797
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-3.1.7.1-error-message.patch
@@ -0,0 +1,11 @@
+--- pdns-recursor-3.1.7.1/rec_channel.cc
++++ pdns-recursor-3.1.7.1/rec_channel.cc
+@@ -100,7 +100,7 @@
+   strcpy(remote.sun_path,(path+"/"+fname).c_str());
+   if(::connect(d_fd, (sockaddr*)&remote, sizeof(remote)) < 0) {
+     unlink(d_local.sun_path);
+-    throw AhuException("Unable to connect to remote '"+path+fname+"': "+string(strerror(errno)));
++    throw AhuException("Unable to connect to remote '"+path+"/"+fname+"': "+string(strerror(errno)));
+   }
+ }
+ 
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild
new file mode 100644
index 000000000000..c17cbf21e7a0
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.7.1.ebuild,v 1.1 2009/08/03 19:34:12 swegener Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND=">=dev-libs/boost-1.33.1
+	lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+	!<net-dns/pdns-2.9.20-r1"
+
+pkg_setup() {
+	filter-flags -ftree-vectorize
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}"/${P}-error-message.patch
+
+	sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
+}
+
+src_compile() {
+	emake \
+		CC="$(tc-getCC)" \
+		CXX="$(tc-getCXX)" \
+		OPTFLAGS="" \
+		LUA_LIBS_CONFIG="-llua" \
+		LUA_CPPFLAGS_CONFIG="" \
+		LUA="$(use lua && echo 1)" \
+		|| die "emake failed"
+}
+
+src_install() {
+	dosbin pdns_recursor rec_control || die "dosbin failed"
+	doman pdns_recursor.1 rec_control.1 || die "doman failed"
+
+	insinto /etc/powerdns
+	doins "${FILESDIR}"/recursor.conf || die "doins failed"
+
+	doinitd "${FILESDIR}"/precursor || die "doinitd failed"
+
+	# Pretty ugly, uh?
+	dodir /var/lib/powerdns/var/lib
+	dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}
-- 
cgit v1.2.3-65-gdbad