From 820ee07efff4e8ccbb8d30a3b7963a8f50b080a7 Mon Sep 17 00:00:00 2001
From: Maxim Koltsov <maksbotan@gentoo.org>
Date: Thu, 2 Feb 2012 17:24:46 +0000
Subject: Big leechcraft bump to 0.4.99, thanks to 0xd34df00d

(Portage version: 2.1.10.44/cvs/Linux x86_64)
---
 net-im/leechcraft-azoth/ChangeLog                  |  8 ++-
 .../leechcraft-azoth-0.4.99.ebuild                 | 69 ++++++++++++++++++++++
 2 files changed, 76 insertions(+), 1 deletion(-)
 create mode 100644 net-im/leechcraft-azoth/leechcraft-azoth-0.4.99.ebuild

(limited to 'net-im')

diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
index bfd3571fce22..7b2dd0d00759 100644
--- a/net-im/leechcraft-azoth/ChangeLog
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/leechcraft-azoth
 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.10 2012/01/24 18:18:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.11 2012/02/02 17:24:46 maksbotan Exp $
+
+*leechcraft-azoth-0.4.99 (02 Feb 2012)
+
+  02 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+  +leechcraft-azoth-0.4.99.ebuild:
+  Bump app-editors/leechcraft-popishu to 0.4.99, thanks to 0xd34df00d
 
   24 Jan 2012; Johannes Huber <johu@gentoo.org> leechcraft-azoth-9999.ebuild:
   Non maintainer commit. Change dep according package move.
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.4.99.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.99.ebuild
new file mode 100644
index 000000000000..b77c3a74e6d8
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.99.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.4.99.ebuild,v 1.1 2012/02/02 17:24:46 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+		+depester +embedmedia +herbicide +hili +isterique +juick +lastseen
+		+metacontacts +modnok +nativeemoticons +otroid +p100q +rosenthal
+		+standardstyles +xoox +xtazy"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+		x11-libs/qt-webkit
+		x11-libs/qt-multimedia
+		otroid? ( net-libs/libotr )
+		xoox? ( net-libs/qxmpp[extras] media-libs/speex )
+		xtazy? ( x11-libs/qt-dbus )
+		crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+RDEPEND="${DEPEND}
+	modnok? (
+		|| (
+			media-gfx/imagemagick
+			media-gfx/graphicsmagick[imagemagick]
+		)
+		virtual/latex-base
+	)"
+
+src_configure() {
+	local mycmakeargs="
+		$(cmake-utils_use_enable crypt CRYPT)
+		$(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+		$(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+		$(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+		$(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+		$(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+		$(cmake-utils_use_enable depester AZOTH_DEPESTER)
+		$(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+		$(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+		$(cmake-utils_use_enable hili AZOTH_HILI)
+		$(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+		$(cmake-utils_use_enable juick AZOTH_JUICK)
+		$(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+		$(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+		$(cmake-utils_use_enable modnok AZOTH_MODNOK)
+		$(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+		$(cmake-utils_use_enable otroid AZOTH_OTROID)
+		$(cmake-utils_use_enable p100q AZOTH_P100Q)
+		$(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+		$(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+		$(cmake-utils_use_enable xoox AZOTH_XOOX)
+		$(cmake-utils_use_enable xtazy AZOTH_XTAZY)"
+
+	cmake-utils_src_configure
+}
+
+pkg_postinst() {
+	if use rosenthal; then
+		elog "You have enabled the Azoth Rosenthal plugin for"
+		elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+		elog "so install the ones for languages you use to enable"
+		elog "spellchecking."
+	fi
+}
-- 
cgit v1.2.3-65-gdbad