summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/msgpack/msgpack-0.4.1.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-0.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/msgpack/msgpack-0.4.1.ebuild b/dev-libs/msgpack/msgpack-0.4.1.ebuild
new file mode 100644
index 0000000..b3518d0
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit autotools eutils
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/45536/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-util/gtest )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-test.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}