summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patchsets/skey/1.1.5/03_all_fPIC.patch')
-rw-r--r--patchsets/skey/1.1.5/03_all_fPIC.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/patchsets/skey/1.1.5/03_all_fPIC.patch b/patchsets/skey/1.1.5/03_all_fPIC.patch
new file mode 100644
index 0000000..8a91192
--- /dev/null
+++ b/patchsets/skey/1.1.5/03_all_fPIC.patch
@@ -0,0 +1,12 @@
+--- skey-1.1.5-orig/Makefile.in
++++ skey-1.1.5/Makefile.in
+@@ -50,6 +50,9 @@
+
+ ${LIBOBJS}: config.h
+
++${LIBOBJS}: %.o: %.c
++ ${CC} ${CFLAGS} -fPIC -c $< -o $@
++
+ libskey.a: ${LIBOBJS}
+ ${AR} rv $@ ${LIBOBJS}
+ ${RANLIB} $@