summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/amdstream/files/amdstream-2.6-x11.patch')
-rw-r--r--dev-util/amdstream/files/amdstream-2.6-x11.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/amdstream/files/amdstream-2.6-x11.patch b/dev-util/amdstream/files/amdstream-2.6-x11.patch
new file mode 100644
index 0000000..05ff3ea
--- /dev/null
+++ b/dev-util/amdstream/files/amdstream-2.6-x11.patch
@@ -0,0 +1,33 @@
+--- a/samples/opencl/cl/app/BoxFilterGL/Makefile
++++ b/samples/opencl/cl/app/BoxFilterGL/Makefile
+@@ -29,7 +29,7 @@
+ ifdef MINGW
+ LLIBS += glew$(BITS).dll glut$(BITS) opengl32 glu32 gdi32
+ else
+- LLIBS += glut GLEW GL GLU
++ LLIBS += glut GLEW GL GLU X11
+ endif
+ else
+ LLIBS += glut$(BITS) GLEW$(BITS)
+--- a/samples/opencl/cl/app/URNGNoiseGL/Makefile
++++ b/samples/opencl/cl/app/URNGNoiseGL/Makefile
+@@ -29,7 +29,7 @@
+ ifdef MINGW
+ LLIBS += glew$(BITS).dll glut$(BITS) opengl32 glu32 gdi32
+ else
+- LLIBS += glut GLEW GL GLU
++ LLIBS += glut GLEW GL GLU X11
+ endif
+ else
+ LLIBS += glut$(BITS) GLEW$(BITS)
+--- a/samples/opencl/cl/app/SimpleGL/Makefile
++++ b/samples/opencl/cl/app/SimpleGL/Makefile
+@@ -29,7 +29,7 @@
+ ifdef MINGW
+ LLIBS += glew$(BITS).dll glut$(BITS) opengl32 glu32 gdi32
+ else
+- LLIBS += glut GLEW GL GLU
++ LLIBS += glut GLEW GL GLU X11
+ endif
+ else
+ LLIBS += glut$(BITS) GLEW$(BITS)