aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2002-06-14 20:30:31 +0000
committerSkip Montanaro <skip@pobox.com>2002-06-14 20:30:31 +0000
commit57454e57f83b407dd2653cbfcead7c9801beeff0 (patch)
tree9912260067e5a620752d6a218637578d58cd70da /Modules/dbmmodule.c
parentClean up descriptions of PyObject_RichCompare() and PyObject_RichCompareBool() (diff)
downloadcpython-57454e57f83b407dd2653cbfcead7c9801beeff0.tar.gz
cpython-57454e57f83b407dd2653cbfcead7c9801beeff0.tar.bz2
cpython-57454e57f83b407dd2653cbfcead7c9801beeff0.zip
This introduces stricter library/header file checking for the Berkeley DB
library. Since multiple versions can be installed simultaneously, it's crucial that you only select libraries and header files which are compatible with each other. Version checking is done from highest version to lowest. Building using version 1 of Berkeley DB is disabled by default because of the hash file bugs people keep rediscovering. It can be enabled by uncommenting a few lines in setup.py. Closes patch 553108.
Diffstat (limited to 'Modules/dbmmodule.c')
-rw-r--r--Modules/dbmmodule.c3
1 files changed, 0 insertions, 3 deletions
diff --git a/Modules/dbmmodule.c b/Modules/dbmmodule.c
index 056af4986b2..bbc70a8427a 100644
--- a/Modules/dbmmodule.c
+++ b/Modules/dbmmodule.c
@@ -18,9 +18,6 @@ static char *which_dbm = "ndbm";
#else
static char *which_dbm = "GNU gdbm"; /* EMX port of GDBM */
#endif
-#elif defined(HAVE_DB1_NDBM_H)
-#include <db1/ndbm.h>
-static char *which_dbm = "BSD db";
#elif defined(HAVE_GDBM_NDBM_H)
#include <gdbm/ndbm.h>
static char *which_dbm = "GNU gdbm";