aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2008-04-25 16:11:04 +0000
committerMark Dickinson <dickinsm@gmail.com>2008-04-25 16:11:04 +0000
commit65134662707f270146122ffd71b4a6ac10536e4d (patch)
tree23e8b43a283fd0fd6a5abfc8d680171f953276fa /configure.in
parentAdd from_buffer and from_buffer_copy class methods to ctypes types. (diff)
downloadcpython-65134662707f270146122ffd71b4a6ac10536e4d.tar.gz
cpython-65134662707f270146122ffd71b4a6ac10536e4d.tar.bz2
cpython-65134662707f270146122ffd71b4a6ac10536e4d.zip
Issue #1496032. Add -mieee to BASECFLAGS on alpha, when gcc is
the compiler. This should(?) help to fix failures in test_math and test_cmath on Linux/alpha. Also add configure message reporting the result of uname -m, as a debugging aid.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a246b2dec30..a4793aa999e 100644
--- a/configure.in
+++ b/configure.in
@@ -333,6 +333,10 @@ AC_SUBST(EXPORT_MACOSX_DEPLOYMENT_TARGET)
CONFIGURE_MACOSX_DEPLOYMENT_TARGET=
EXPORT_MACOSX_DEPLOYMENT_TARGET='#'
+AC_MSG_CHECKING(machine type as reported by uname -m)
+ac_sys_machine=`uname -m`
+AC_MSG_RESULT($ac_sys_machine)
+
# checks for alternative programs
# compiler flags are generated in two sets, BASECFLAGS and OPT. OPT is just
@@ -817,6 +821,16 @@ yes)
then
BASECFLAGS="$BASECFLAGS -fno-strict-aliasing"
fi
+
+ # if using gcc on alpha, use -mieee to get (near) full IEEE 754
+ # support. Without this, treatment of subnormals doesn't follow
+ # the standard.
+ case $ac_sys_machine in
+ alpha*)
+ BASECFLAGS="$BASECFLAGS -mieee"
+ ;;
+ esac
+
case $ac_sys_system in
SCO_SV*)
BASECFLAGS="$BASECFLAGS -m486 -DSCO5"