diff options
author | Christian Heimes <christian@python.org> | 2021-11-22 13:09:14 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-22 12:09:14 +0100 |
commit | 29699a2a2aa2f0d6e790beeae55967fc2f35fe50 (patch) | |
tree | 48030cd4d4e747d2bc0c74d4090f18fa30697adb /setup.py | |
parent | bpo-45847: Port _lfprof, _opcode, _asyncio, _queue, _statistics, and _typing ... (diff) | |
download | cpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.tar.gz cpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.tar.bz2 cpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.zip |
bpo-45847: Various PY_STDLIB_MOD cleanups (GH-29697)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 4 insertions, 6 deletions
@@ -397,6 +397,10 @@ class PyBuildExt(build_ext): pass else: # not migrated to MODULE_{name} yet. + self.announce( + f'WARNING: Makefile is missing module variable for "{ext.name}"', + level=2 + ) self.extensions.append(ext) def update_extension_flags(self, ext): @@ -995,12 +999,6 @@ class PyBuildExt(build_ext): # complex math library functions self.addext(Extension('cmath', ['cmathmodule.c'])) - # time libraries: librt may be needed for clock_gettime() - time_libs = [] - lib = sysconfig.get_config_var('TIMEMODULE_LIB') - if lib: - time_libs.append(lib) - # libm is needed by delta_new() that uses round() and by accum() that # uses modf(). self.addext(Extension('_datetime', ['_datetimemodule.c'])) |