diff options
author | Erlend Egeberg Aasland <erlend.aasland@innova.no> | 2021-11-22 14:02:27 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-22 14:02:27 +0100 |
commit | 5b946cadaa1175a5caae98bd2d309840bea52a58 (patch) | |
tree | a02528275f2dc25fafd17ce8b9a6c3827891feb3 /setup.py | |
parent | bpo-45847: Various PY_STDLIB_MOD cleanups (GH-29697) (diff) | |
download | cpython-5b946cadaa1175a5caae98bd2d309840bea52a58.tar.gz cpython-5b946cadaa1175a5caae98bd2d309840bea52a58.tar.bz2 cpython-5b946cadaa1175a5caae98bd2d309840bea52a58.zip |
bpo-45847: Port fcntl to Py_STDLIB_MOD (GH-29696)
Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 1 insertions, 6 deletions
@@ -1030,12 +1030,7 @@ class PyBuildExt(build_ext): # supported...) # fcntl(2) and ioctl(2) - libs = [] - if (self.config_h_vars.get('FLOCK_NEEDS_LIBBSD', False)): - # May be necessary on AIX for flock function - libs = ['bsd'] - self.add(Extension('fcntl', ['fcntlmodule.c'], - libraries=libs)) + self.addext(Extension('fcntl', ['fcntlmodule.c'])) # grp(3) self.addext(Extension('grp', ['grpmodule.c'])) self.addext(Extension('spwd', ['spwdmodule.c'])) |