diff options
author | Roland McGrath <roland@gnu.org> | 1996-06-16 01:27:54 +0000 |
---|---|---|
committer | Roland McGrath <roland@gnu.org> | 1996-06-16 01:27:54 +0000 |
commit | a23db8e4af794430fe69c17bd884f03669d307d7 (patch) | |
tree | 2f5c0e5daf975595266cd58a12d7f71958fdde23 /Makerules | |
parent | Fri Jun 14 01:51:47 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu> (diff) | |
download | glibc-a23db8e4af794430fe69c17bd884f03669d307d7.tar.gz glibc-a23db8e4af794430fe69c17bd884f03669d307d7.tar.bz2 glibc-a23db8e4af794430fe69c17bd884f03669d307d7.zip |
Sat Jun 15 18:13:43 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>
* sysdeps/unix/sysv/linux/Dist: Add sys/klog.h.
* elf/dl-open.c (_dl_open): Remove PARENT argument, pass null.
* elf/link.h: Update prototype.
* elf/dl-load.c (_dl_map_object): If dependents' DT_RPATHs don't find
NAME, try the DT_RPATH of the executable itself if dynamic.
* elf/dlopen.c (dlopen): Don't pass first arg to _dl_open.
* elf/dl-load.c (_dl_map_object): Exit DT_RPATH checking loop when an
open succeeds.
* Makerules (build-shlib): Give -L opts for each elt of $(rpath-link).
* sysdeps/mach/hurd/Makefile (sysdep-LDFLAGS): Variable removed.
(rpath-link): Append to this instead.
Diffstat (limited to 'Makerules')
-rw-r--r-- | Makerules | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -486,7 +486,7 @@ define build-shlib $(LINK.o) -shared -o $@ $(sysdep-LDFLAGS) $(config-LDFLAGS) \ -Wl,-soname=lib$(libprefix)$(@F:lib%.so=%).so$($(@F)-version) \ $(LDFLAGS.so) $(LDFLAGS-$(@F:lib%.so=%).so) \ - -Wl,-rpath-link=$(common-objdir) \ + -L$(subst :, -L,$(rpath-link)) -Wl,-rpath-link=$(rpath-link) \ -Wl,--whole-archive $^ $(no-whole-archive) \ $(LDLIBS-$(@F:lib%.so=%).so) endef |