From 82642980ce69b3be456725fa3b86fc684b53716a Mon Sep 17 00:00:00 2001
From: Mark Loeser
Date: Mon, 27 Feb 2006 23:18:14 +0000
Subject: Change -- to where appropriate. Finish up the autotools doc
git-svn-id: svn+ssh://svn.gentoo.org/var/svnroot/devmanual/trunk@11 176d3534-300d-0410-8db8-84e73ed771c3
---
ebuild-writing/file-format/text.xml | 4 +-
ebuild-writing/messages/text.xml | 6 +-
ebuild-writing/use-conditional-code/text.xml | 2 +-
ebuild-writing/using-eclasses/text.xml | 2 +-
ebuild-writing/variables/text.xml | 2 +-
general-concepts/autotools/text.xml | 634 ++++++++++++++++++++++++-
general-concepts/dependencies/text.xml | 2 +-
general-concepts/digest-and-manifest/text.xml | 2 +-
general-concepts/ebuild-revisions/text.xml | 4 +-
general-concepts/filesystem/text.xml | 2 +-
general-concepts/herds-and-projects/text.xml | 4 +-
general-concepts/install-destinations/text.xml | 4 +-
general-concepts/mirrors/text.xml | 4 +-
general-concepts/overlay/text.xml | 2 +-
general-concepts/sandbox/text.xml | 2 +-
general-concepts/slotting/text.xml | 6 +-
general-concepts/use-flags/text.xml | 4 +-
general-concepts/user-environment/text.xml | 4 +-
quickstart/text.xml | 22 +-
19 files changed, 666 insertions(+), 46 deletions(-)
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index 499a60c..2a439da 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -98,7 +98,7 @@ Overall, this gives us a filename like libfoo-1.2.5b_pre5-r2.ebuild.
All ebuilds committed to the tree should have a three line header immediately at
the start indicating copyright. This must be an exact copy of the contents of
$(portageq portdir)/header.txt. Ensure that the $Header: $ line is not
-modified manually -- CVS will handle this line specially.
+modified manually CVS will handle this line specially.
@@ -128,7 +128,7 @@ tabs for indentation) when you commit.
Where possible, try to keep lines no wider than 80 positions. A
-'position' is generally the same as a character -- tabs are four
+'position' is generally the same as a character tabs are four
positions wide, and multibyte characters are just one position wide.
diff --git a/ebuild-writing/messages/text.xml b/ebuild-writing/messages/text.xml
index bcb002e..fdc5477 100644
--- a/ebuild-writing/messages/text.xml
+++ b/ebuild-writing/messages/text.xml
@@ -33,7 +33,7 @@ with their fancy leading markers.
There are a number of functions available to assist here. The `echo` bash
-internal is the simplest -- it simply displays its parameters as a message.
+internal is the simplest it simply displays its parameters as a message.
@@ -86,14 +86,14 @@ is mainly used for displaying additional error details before bailing out.
For really important messages, eutils.eclass provides ebeep and
epause. The former will beep a number of times, and the latter will pause
for several seconds to allow the user to read any messages. Both can be disabled
-by the user -- you must not attempt to override the user's preference in
+by the user you must not attempt to override the user's preference in
this. ebeep takes an optional parameter specifying how many times to beep.
epause takes an optional parameter (which must be an exact whole number)
specifying for how long it should sleep.
-Do not abuse these functions -- better to save them for when things really are
+Do not abuse these functions better to save them for when things really are
important.
diff --git a/ebuild-writing/use-conditional-code/text.xml b/ebuild-writing/use-conditional-code/text.xml
index 84fc490..79d580b 100644
--- a/ebuild-writing/use-conditional-code/text.xml
+++ b/ebuild-writing/use-conditional-code/text.xml
@@ -52,7 +52,7 @@ function available.
-You must not rely upon use producing an output -- this no longer happens.
+You must not rely upon use producing an output this no longer happens.
If you really need output displayed, use the usev function. The
useq function is available for explicitly requesting no output.
diff --git a/ebuild-writing/using-eclasses/text.xml b/ebuild-writing/using-eclasses/text.xml
index 171d967..fdf8da0 100644
--- a/ebuild-writing/using-eclasses/text.xml
+++ b/ebuild-writing/using-eclasses/text.xml
@@ -21,7 +21,7 @@ how to use an eclass which has already been written.
To use an eclass, it must be 'inherited'. This is done via the inherit
function, which is provided by ebuild.sh. The inherit statement must
come at the top of the ebuild, *before* any functions. Conditional inherits are
-illegal (except where the inheritance criteria are cache-constant -- see `The
+illegal (except where the inheritance criteria are cache-constant see `The
Portage Cache`_).
diff --git a/ebuild-writing/variables/text.xml b/ebuild-writing/variables/text.xml
index d6f5aec..a13202a 100644
--- a/ebuild-writing/variables/text.xml
+++ b/ebuild-writing/variables/text.xml
@@ -261,7 +261,7 @@ See `Keywording`_ for how to handle this variable.
Conditional source files based upon USE flags are allowed using the usual
flag? ( ) syntax. This is often useful for arch-specific code or for binary
-packages -- downloading sparc binaries on ppc would be a waste of bandwidth.
+packages downloading sparc binaries on ppc would be a waste of bandwidth.
diff --git a/general-concepts/autotools/text.xml b/general-concepts/autotools/text.xml
index 3541d70..6224ebd 100644
--- a/general-concepts/autotools/text.xml
+++ b/general-concepts/autotools/text.xml
@@ -16,17 +16,17 @@ when working with ebuilds:
-
- Finding and correcting build issues is often easier if the build system is
- not seen simply as a scary black box.
+ Finding and correcting build issues is often easier if the build system is
+ not seen simply as a scary black box.
-
- The autotools input files can help when determining a package's build-time
- dependencies.
+ The autotools input files can help when determining a package's build-time
+ dependencies.
-
- The risk of accidentally breaking something by patching the wrong file at the
- wrong time is greatly reduced if the relationship between the build system
- files is understood.
+ The risk of accidentally breaking something by patching the wrong file at the
+ wrong time is greatly reduced if the relationship between the build system
+ files is understood.
Ebuilds may have a Gentoo revision number associated with them. This is a
--rX suffix, where X is an integer -- see `File Naming Rules`_. This
+-rX suffix, where X is an integer see `File Naming Rules`_. This
component must only be used for Gentoo changes, not upstream releases. By
default, -r0 is implied and should not be specified manually.
Ebuilds should have their -rX incremented whenever a change is made which
-will make a substantial difference to what gets installed by the package -- by
+will make a substantial difference to what gets installed by the package by
substantial, we generally mean "something for which many users would want to
upgrade". This is usually for bugfixes.
diff --git a/general-concepts/filesystem/text.xml b/general-concepts/filesystem/text.xml
index e2eac96..64f9ac4 100644
--- a/general-concepts/filesystem/text.xml
+++ b/general-concepts/filesystem/text.xml
@@ -58,7 +58,7 @@ which is not modified at runtime.
-Try to avoid installing unnecessary things into /etc -- every file in there
+Try to avoid installing unnecessary things into /etc every file in there
is additional work for the system administrator. In particular, non-text files
and files that are not intended for system administrator usage should be moved
to /usr/share.
diff --git a/general-concepts/herds-and-projects/text.xml b/general-concepts/herds-and-projects/text.xml
index c6f9811..c4ff6d5 100644
--- a/general-concepts/herds-and-projects/text.xml
+++ b/general-concepts/herds-and-projects/text.xml
@@ -8,7 +8,7 @@
A herd is a collection of developers who maintain a collection of related
packages. A herd has an associated email address which can be used for bugzilla
-assignments. This email address is not always herdname@gentoo.org -- for
+assignments. This email address is not always herdname@gentoo.org for
example, because of the way Gentoo's email aliases are set up, the cron herd
use cron-bugs@gentoo.org (aliases cannot match system usernames).
@@ -19,7 +19,7 @@ may have herds associated with it.
-Sometimes herd and project names overlap -- for example, the sparc project
+Sometimes herd and project names overlap for example, the sparc project
has an associated sparc herd which maintains sparc-specific packages (such
as the silo bootloader). This is not always the case.
diff --git a/general-concepts/install-destinations/text.xml b/general-concepts/install-destinations/text.xml
index ff51cdf..9e9fe43 100644
--- a/general-concepts/install-destinations/text.xml
+++ b/general-concepts/install-destinations/text.xml
@@ -8,13 +8,13 @@
When an ebuild runs the src_install phase, it installs an image of the
package in question from ${S} into ${D}. Ebuilds must not attempt to
-perform any operation upon the live filesystem at this stage -- this will break
+perform any operation upon the live filesystem at this stage this will break
binaries, and will (often) cause a sandbox violation notice.
When installing, portage will install the image in ${D} into ${ROOT}. By
-default, ${ROOT} points to /, although the user can alter this -- for
+default, ${ROOT} points to /, although the user can alter this for
example, the user may be building a minimal image for another system in a
different location. If your package must operate on the live filesystem (for
example, to create some cache files during pkg_postinst), you must ensure
diff --git a/general-concepts/mirrors/text.xml b/general-concepts/mirrors/text.xml
index 47051db..dbbd855 100644
--- a/general-concepts/mirrors/text.xml
+++ b/general-concepts/mirrors/text.xml
@@ -14,7 +14,7 @@ trying the original upstream location.
-This is generally desired behaviour -- upstream mirrors are prone to being
+This is generally desired behaviour upstream mirrors are prone to being
rearranged, tidied out or having files modified.
Packages can support having multiple versions installed simultaneously. This is
-useful for libraries which may have changed interfaces between versions -- for
+useful for libraries which may have changed interfaces between versions for
example, the gtk+ package can install both versions 1.2 and 2.6 in
parallel. This feature is called slotting.
Most packages have no need for slotting. These packages specify SLOT="0" in
-the ebuilds. This is not the same as specifying an empty slot -- an empty
+the ebuilds. This is not the same as specifying an empty slot an empty
slot means "disable slotting entirely", and should not be used.
@@ -43,7 +43,7 @@ It is not possible to DEPEND upon a package in a specific slot.
Currently portage will accept an arbitrary string for the value of SLOT. For
future compatibility, it is recommended that slots contain only characters which
are allowed in an ebuild name or version (alphanumerics, hypens, full stops,
-underscores, the plus character) -- other characters may cause problems with
+underscores, the plus character) other characters may cause problems with
future portage enhancements.
User environment variables and make.conf settings get passed on to ebuilds.
-This can be useful -- it's how CFLAGS and friends work, for example -- but
+This can be useful it's how CFLAGS and friends work, for example but
it can also result in nasty build-breaking variables like LANG and
LC_ALL getting through. Currently no sanitisation is performed upon the
environment.
@@ -52,7 +52,7 @@ respected (selective filtering is fine, but outright ignoring is not). Ignoring
-
Ignoring march/mcpu may force kernel or software emulation for certain
- opcodes on some architectures. This can be very slow -- for example,
+ opcodes on some architectures. This can be very slow for example,
openssl built for SPARC v7 but run on v9 is around five times slower for
RSA operations.
diff --git a/quickstart/text.xml b/quickstart/text.xml
index 5eb5753..c3a6907 100644
--- a/quickstart/text.xml
+++ b/quickstart/text.xml
@@ -7,7 +7,7 @@
This page provides a very brief introduction to ebuild
writing. It does not attempt to cover many of the details or problems
-that will be encountered by developers -- rather, it gives some
+that will be encountered by developers rather, it gives some
trivial examples which may be of use when trying to grasp the basic
idea of how ebuilds work.
@@ -109,7 +109,7 @@ The SRC_URI tells Portage the address to use for downloading
the source tarball. Here, mirror://sourceforge/ is a special
notation meaning "any of the Sourceforge mirrors". The
${P} is a read-only variable set by Portage which is the package's
-name and version -- in this case, it would be ctags-5.5.4.
+name and version in this case, it would be ctags-5.5.4.
@@ -119,7 +119,7 @@ you've not seen slots before, either just use "0" or read `Slot
The KEYWORDS variable is set to archs upon which this ebuild has been
-tested. We use ~ keywords for newly written ebuilds -- packages are not
+tested. We use ~ keywords for newly written ebuilds packages are not
committed straight to stable, even if they seem to work. See `Keywording`_ for
details.
@@ -135,17 +135,17 @@ Next, a function named src_compile. Portage will call this
function when it wants to compile the package. The econf
function is a wrapper for calling ./configure, and emake
is a wrapper for make. In both cases, the common || die
-"something went wrong" idiom is used -- this is to
+"something went wrong" idiom is used this is to
ensure that if for some reason an error occurs, portage will stop
rather than trying to continue with the install.
The src_install function is called by portage when it wants
-to install the package. A slight subtlety here -- rather than
+to install the package. A slight subtlety here rather than
installing straight to the live filesystem, we must install to a
special location which is given by the ${D} variable (portage sets
-this -- see `Install Destinations`_ and `Sandbox`_). Again, we check
+this see `Install Destinations`_ and `Sandbox`_). Again, we check
for errors.
@@ -166,7 +166,7 @@ files into the relevant part of /usr/share/doc.
Ebuilds can define other functions (see `Ebuild Functions`_). In all cases,
portage provides a reasonable default implementation which quite often does the
'right thing'. There was no need to define a src_unpack function here, for
-example -- this function is used to do any unpacking of tarballs or patching of
+example this function is used to do any unpacking of tarballs or patching of
source files, but the default implementation does everything we need.