diff options
author | Sebastian Pipping <sebastian@pipping.org> | 2012-07-10 00:44:18 +0200 |
---|---|---|
committer | Sebastian Pipping <sebastian@pipping.org> | 2012-07-10 00:44:18 +0200 |
commit | 76652966ae35c0e33c10ff1d95cfb30ea90c45fb (patch) | |
tree | 67bfb96574ec9cf733ccfd1eb1a615b37e78f8d6 | |
parent | Restore previous handling of real_root due to report of regressions (bug #419... (diff) | |
parent | Fix linking of unionfs-fuse 0.24 (diff) | |
download | genkernel-76652966ae35c0e33c10ff1d95cfb30ea90c45fb.tar.gz genkernel-76652966ae35c0e33c10ff1d95cfb30ea90c45fb.tar.bz2 genkernel-76652966ae35c0e33c10ff1d95cfb30ea90c45fb.zip |
Merge branch 'bug-425080'
-rw-r--r-- | ChangeLog | 7 | ||||
-rwxr-xr-x | gen_compile.sh | 4 | ||||
-rw-r--r-- | patches/fuse/2.8.6/fuse-2.8.6-glibc-2.14.patch | 10 |
3 files changed, 19 insertions, 2 deletions
@@ -5,6 +5,13 @@ # Distributed under the GPL v2 # $Id$ + 09 Jul 2012; Sebastian Pipping <sping@gentoo.org> gen_compile.sh: + Fix linking of unionfs-fuse 0.24 + + 09 Jul 2012; Sebastian Pipping <sping@gentoo.org> + patches/fuse/2.8.6/fuse-2.8.6-glibc-2.14.patch: + Allow compilation of FUSE 2.8.6 with glibc 2.14 (bug #370411) + 09 Jul 2012; Sebastian Pipping <sping@gentoo.org> defaults/initrd.scripts: Restore previous handling of real_root due to report of regressions (bug #419965) diff --git a/gen_compile.sh b/gen_compile.sh index 3344dc44..cbd3432f 100755 --- a/gen_compile.sh +++ b/gen_compile.sh @@ -578,7 +578,7 @@ compile_fuse() { cd "${FUSE_DIR}" apply_patches fuse ${FUSE_VER} print_info 1 'fuse: >> Configuring...' - ./configure --disable-kernel-module --disable-example >> ${LOGFILE} 2>&1 || + ./configure --disable-example >> ${LOGFILE} 2>&1 || gen_die 'Configuring fuse failed!' print_info 1 'fuse: >> Compiling...' MAKE=${UTILS_MAKE} compile_generic "" "" @@ -616,7 +616,7 @@ compile_unionfs_fuse() { apply_patches unionfs-fuse ${UNIONFS_FUSE_VER} print_info 1 'unionfs-fuse: >> Compiling...' sed -i "/^\(CFLAGS\|CPPFLAGS\)/s:^\\(.*\\)$:\\1 -static -I${TEMP}/${FUSE_DIR}/include -L${TEMP}/${FUSE_DIR}/lib/.libs:" Makefile src/Makefile - sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -static -L${TEMP}/${FUSE_DIR}/lib/.libs \1 -ldl -lrt:" Makefile src/Makefile + sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -static -L${TEMP}/${FUSE_DIR}/lib/.libs \1 -ldl -lpthread -lrt:" Makefile src/Makefile MAKE=${UTILS_MAKE} compile_generic "" "" print_info 1 'unionfs-fuse: >> Copying to cache...' [ -f "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ] || diff --git a/patches/fuse/2.8.6/fuse-2.8.6-glibc-2.14.patch b/patches/fuse/2.8.6/fuse-2.8.6-glibc-2.14.patch new file mode 100644 index 00000000..93713cd7 --- /dev/null +++ b/patches/fuse/2.8.6/fuse-2.8.6-glibc-2.14.patch @@ -0,0 +1,10 @@ +--- util/fusermount.c 2012-07-10 00:18:25.228755618 +0200 ++++ util/fusermount.c 2012-07-10 00:17:47.574226365 +0200 +@@ -9,6 +9,7 @@ + + #include <config.h> + ++#define _GNU_SOURCE /* for clone */ + #include "mount_util.h" + #include <stdio.h> + #include <stdlib.h> |